1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Think I removed something important from the database

Discussion in 'Troubleshooting and Problems' started by Biirds, Feb 16, 2013.

  1. Biirds

    Biirds Member


    I was trying to remove some files from the database that belongs to a add-on, but I think I removed some things that belongs to Xenforo. For example, an unregistered user can no longer see the forum, it says that he has to be logged in to do that. The user still has the allowance in the permission options though. There are also some errors almost everywhere.

    Not really sure what I could do.
  2. Dan

    Dan Well-Known Member

    Restore a backup? That maybe the only way
  3. Lost

    Lost Well-Known Member

    Restore the database from backup?

    Edit: Ninja'd by goblues.
    Dan likes this.
  4. Biirds

    Biirds Member

    Well... I was kind of stupid and did not took a database backup before everything went wrong.

    I have done a file health check in the xenforo admin and this is the error I get:
    File does not contain expected contents.
    Could I restore that somehow?

  5. Dan

    Dan Well-Known Member

    You could indeed. Just redownload the xenforo package and replace that file only.
  6. Biirds

    Biirds Member

    Yes, I have tried to do that but same issue. I have the option to do a fresh install.. could I do that without everything other that I have in the database disappearing.. like members etc?
  7. borbole

    borbole Well-Known Member

    It looks like you removed files from the forum folder and nothing from the database. They are 2 entirely different things.

    Anyway, do not do a fresh install but simply download a copy of xenforo from your customer area and then overwrite your forum files with them. That would take care to replace whatever file/s that you have deleted.
  8. Biirds

    Biirds Member

    Hmm.. I have done exactly as you say but it still gives me that error message when I run "file health check". There are no errors in the "Server error log". I'm pretty sure removed something from my database, becasue I was removing some files from there, and then it stopped working.
  9. Brandon Sheley

    Brandon Sheley Well-Known Member

    I'm not sure if it will work, but you might try to run the upgrade like you were upgrading your forum. This may repopulate your database.
    I'd suggest backing up just to be sure.
  10. borbole

    borbole Well-Known Member

    There are no files in the database. What exactly did you remove? You will have to be specific and not vague with I removed some files here and some there.

    Anyway, if you removed something from the db most likely you would have had a db error message and not missing file ones.

    P.s. A link to your forum would help too.
    Brandon Sheley likes this.
  11. Biirds

    Biirds Member

    Thanks for trying to help me. I will try to explain exactly what I've done.. sorry for my vague information.

    I had a add-on called LNblog on my site that I wanted to remove, because I wanted to install another blog add-on. When I tried to remove the add-on I got a error message telling me that the files to be able to perform the uninstall wasn't there. When I finally was able to remove the add-on and was trying to install the other add-on it was something in the database that was conflicting with the new add-on. My old add-on had some information in the database that I had to remove in order to install my new add-on correctly.

    I went into MySQL and did a search for "LNblog". I removed everything that had a reference to lnblog in the database and now I have the error that I got now. I'm sorry, but I can't remember which files in the database I was removing, but I think it was for instance something that had to do with permissions. :

    What is wrong:
    If I go to the site I am presented with this message: "You must be logged-in to do that". If I log in with my administrator account I'm able to go to the admin cp and reach everything else on the site. If I log in with another user I'm presented with the same message: "You must be logged in to do that".

  12. XeStorm

    XeStorm Member

  13. XeStorm

    XeStorm Member

  14. tenants

    tenants Well-Known Member

    What does the actual error say in your Admin control Panel
    (ACP >> Tools > Server Error Log):
    admin.php?logs/server-error (click on the error and paste the Error Info, Stack Trace and Request State here)

    Also, can you try rebuilding your caches (all of them):
    (ACP >> Tools > Rebuild Caches)

    And humor me... also try un-installing an un-related plugin and then reinstalling it

    I have a suspicion you've deleted it from the xf_addon table

    This addon should look roughly like this:
    [addon_id, title, version_string, version_id, url, install_callback_class, install_callback_method uninstall_callback_class, uninstall_callback_method, active]
    [LNBlog, LeafNet Blog, xxxx, 1.1, 4, http://xenforo.com/community/threads/ln-blog.12701/, LNBlog_Manufacture, build, LNBlog_Manufacture, destroy, 0]
  15. Biirds

    Biirds Member

    Hi all!

    Thanks for everyones help. The host had a back-up of my database so we could resolve this issue =).

Share This Page