1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 The Strangest Thing! Error Creating a New Post

Discussion in 'Troubleshooting and Problems' started by MistyMeanor, Nov 3, 2014.

  1. MistyMeanor

    MistyMeanor Active Member

    So I have a long message that I have typed up from Facebook and then had copied to my WordPress blog. I wanted to post it on my forum as well. When I copied/pasted it over to create a new thread, it said this:

    "You don't have permission to access /forums/can-i-take-a-puff-off-of-that.22/add-thread on this server."

    But that isn't what is strange. I just moved hosts, so I figured it had something to do with permissions.

    • I tried typing something in the same category as a test message and it worked. So then I thought it had to do with me doing it on a different computer somehow. But I did a few more tests...
    • I tried doing test threads in different categories of my forum... ones I knew were public viewed and ones that are registered member viewing only. All tests worked.
    • I tried changing the title of the thread in that same category, didn't work.
    • I tried copy/paste of the thread I wanted to posts' content in to the basic text editor without formatting. Didn't work.
    • I tried copy/past of the threads content in to Evernote, and then a basic editor (TextEdit) and THEN re-pasting it to my forum... Didn't work.
    • I tried replying to posts in the same category first with "test messages" and worked. Then with the message I wanted copy/pasted in as a REPLY in same category and Didn't work.
    • I tried posting the message I wanted in OTHER categories, and those didn't work either.

    So bottom line is, this error has SOMETHING to do, I believe, with it being copied/pasted first.
    I do NOT want to re-type it... its quite long.

    BTW... I also tried highlighting all the text and removing all formatting and it still wouldn't let me. I can't post that message any other categories I tried either, but can post in the category I wanted to put it in with anything else I put in the content box. Can't post it as a reply, in that category or any others. Can post replies in that category and any others.

    Has ANYONE here ever heard of an error like this? An error that seemingly has to do with copy/paste content? There is nothing strange textual-wise in the content. Would this be an issue with Xenforo? As I haven't been on my forum in a while, its actually pretty dead to be honest! LOL! But I know at least SOMETIME in the past have copied/pasted things and been just fine. But I haven't used it much since it's last update to 1.3 either. Or, would this have to do with some setting within the server. To me it seems like if it has to do with copy/paste that it's just some bug/glitch in Xenforo. I wouldn't think there is a server setting or permissions that would prevent copy/paste... but maybe I am wrong?!

    UPDATES: THINGS I TRIED BEFORE HITTING "CREATE THREAD."
    • OK SCRATCH my COPY/PASTE theory! I just copied/pasted THIS message here... and it posted! So then it must be something glitchy with where it was copied/pasted FROM... which was my blog.
    • I JUST tried copying it from it's ORIGINAL place, which was on Facebook... and it wouldn't let me post when copied from FB either.
    • I ALSO just tried copying something from my EverNote notes, something that had been typed in my blog first... and I copied/pasted it in to EverNote just in case I lost what I had been writing. I pasted it then in that category I wanted, and it posted to my forum just fine.
    • So this must mean that it has something to do with copying from Facebook that either Xenforo, or my server don't like. I have ZERO idea how to get around this! I just want that content put on my forum! But no matter where I move the content to, or if I remove formatting or anything, it still won't post no matter what I try to do!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The original error message would suggest it was something related to mod_security (or similar).

    You could try contacting your host and they should be able to investigate what triggered it.

    Mod_security should log (or be able to log) the specific rules that are being violated. Once you determine that, you can disable those rules.
     
  3. MistyMeanor

    MistyMeanor Active Member

    Ok, I will see if I can find that log.
     
  4. MistyMeanor

    MistyMeanor Active Member

    How would I find that @Brogan? Because I did a search for mod_security in Xenforo ACP and couldn't find anything.
     
  5. The Forum Heroes

    The Forum Heroes Well-Known Member

    Only your host would have access to Mod_Sec logs and rules. It is not in xF.. It is server level.
     
  6. MistyMeanor

    MistyMeanor Active Member

    Got it... ok makes sense why I couldn't find it then! Will contact them now.
     
  7. UrlJet

    UrlJet Member

    Do you need to paste it to notepad or another editor to removed the facebook formatting / code?
     
  8. MistyMeanor

    MistyMeanor Active Member

    @UrlJet ... see all the things listed above that I tried. Including copying/pasting it into a plain text editor.
     
  9. UrlJet

    UrlJet Member

    opps, the MistyMeanor name gave me a smile and I didn't get that far...Your host will have the key and the ability to reset permission as needed. I'm sure you know that by now.
     

Share This Page