• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

The memcache extension must be loaded for using this backend!

#1
When I tried to enable Memcached backend via library/config.php

It turns out that the memcache extension is not loaded. I use PHP5, and nginx as the webserver.

I'm not sure how to install the appropriate memcache extension, can you please help?

P/S: I have memcached server installed.

PHP:
Zend_Cache_Exception: The memcache extension must be loaded for using this backend ! - library/Zend/Cache.php:209
Generated By: Unknown Account, 6 minutes ago
Stack Trace
#0 /minecraftly/library/Zend/Cache/Backend/Memcached.php(123): Zend_Cache::throwException('The memcache ex...')
#1 /minecraftly/library/Zend/Cache.php(153): Zend_Cache_Backend_Memcached->__construct(Array)
#2 /minecraftly/library/Zend/Cache.php(94): Zend_Cache::_makeBackend('Memcached', Array, false, false)
#3 /minecraftly/library/XenForo/Application.php(762): Zend_Cache::factory('Core', 'Memcached', Array, Array)
#4 [internal function]: XenForo_Application->loadCache(Object(Zend_Config))
#5 /minecraftly/library/XenForo/Application.php(971): call_user_func_array(Array, Array)
#6 /minecraftly/library/XenForo/Application.php(1002): XenForo_Application->lazyLoad('cache', NULL)
#7 /minecraftly/library/XenForo/Application.php(1647): XenForo_Application::get('cache')
#8 /minecraftly/library/XenForo/Model.php(146): XenForo_Application::getCache()
#9 /minecraftly/library/XenForo/Model/DataRegistry.php(81): XenForo_Model->_getCache(true)
#10 /minecraftly/library/XenForo/Dependencies/Abstract.php(147): XenForo_Model_DataRegistry->getMulti(Array)
#11 /minecraftly/library/XenForo/FrontController.php(127): XenForo_Dependencies_Abstract->preLoadData()
#12 /minecraftly/index.php(13): XenForo_FrontController->run()
#13 {main}
Request State
array(3) {
  ["url"] => string(36) "http://m.ly/members/mooneh.477/help/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 
Last edited:

Robust

Well-known member
#2
Well, you need to have Memcache installed on your actual server and you also need the PHP extension memcached. If you installed using apt-get/yum, you can install the extension through that. If you installed by compiling from source, you will need to recompile and add memcached to your compile args, and then run that installation process again.
 
#3
Well, you need to have Memcache installed on your actual server and you also need the PHP extension memcached. If you installed using apt-get/yum, you can install the extension through that. If you installed by compiling from source, you will need to recompile and add memcached to your compile args, and then run that installation process again.
I already had memcached server installed. Just not sure which package/extension to install specifically for Xenforo to work with it.
 

Robust

Well-known member
#4
I already had memcached server installed. Just not sure which package/extension to install specifically for Xenforo to work with it.
http://php.net/manual/en/book.memcached.php
http://pecl.php.net/package/memcached

If you installed using apt-get/yum or a related package manager, the package php5-memcached should be available to install (yum install php5-memcached, apt-get install php5-memcached). If you compiled from source, download the extension and compile and re-compile from source
 
#5
http://php.net/manual/en/book.memcached.php
http://pecl.php.net/package/memcached

If you installed using apt-get/yum or a related package manager, the package php5-memcached should be available to install (yum install php5-memcached, apt-get install php5-memcached). If you compiled from source, download the extension and compile and re-compile from source
Interesting, I installed php5-memcached long ago, and it still showed that error. Not sure if I'm missing anything. :/