XF 1.5 The field '***' was not recognised. (Registration issues)

Tracy Perry

Well-known member
Cookie issue?
Odds are since you are running both with the same domain name. Have you tried the second forum as a sub-domain of the first?
For the second, why not use AEM.ecocitycraft.com?
 

Optic

Well-known member
Pretty sure this is due to either full page caching or a back-end session caching issue. I had a similar issue on LSCache on LiteSpeed and resolved it by making an exception for the registration page (to exclude it from the full page cache for guests).

The registration page has honeypots (randomised values per visit) to help throw off SPAM-bots and your server is likely caching that one session for EVERYONE so there is a mismatch.

Are you using any full page caching? e.g. Varnish, nginx FastCGI, LSCache on Litespeed, etc. ?

Or any of the XenForo back-end caching options?
https://xenforo.com/help/cache/
 

andrewkm

Active member
Pretty sure this is due to either full page caching or a back-end session caching issue. I had a similar issue on LSCache on LiteSpeed and resolved it by making an exception for the registration page (to exclude it from the full page cache for guests).

The registration page has honeypots (randomised values per visit) to help throw off SPAM-bots and your server is likely caching that one session for EVERYONE so there is a mismatch.

Are you using any full page caching? e.g. Varnish, nginx FastCGI, LSCache on Litespeed, etc. ?

Or any of the XenForo back-end caching options?
https://xenforo.com/help/cache/
Thank you. I was using the Xen caching. I've removed that now and here is what my config looks like on both (identical on both) https://ecocitycraft.com and https://ecocitycraft.com/aem

Code:
<?php

$config['db']['host'] = '***';
$config['db']['port'] = '***';
$config['db']['username'] = '***';
$config['db']['password'] = '***';
$config['db']['dbname'] = '***';

$config['superAdmins'] = '***';

// $config['debug'] = true;

// COOKIES WILL WORK ON ANY SUBDOMAIN OF ecocitycraft.com, WITH OR WITHOUT www
$config['cookie'] = array(
   'prefix' => 'xf_',
   'path' => '/',
   'domain' => '.ecocitycraft.com'
);
However I have a new problem.
Now whenever you login on https://ecocitycraft.com/aem it logs you out of https://ecocitycraft.com and vice versa.
How can I fix this issue? (Using different browsers on both websites is fine, obviously because one browser is using one cookie and the other browser another cookie, I'm looking to fix this so one browser can use both forums under the same domain.)
 

Optic

Well-known member
Now whenever you login on https://ecocitycraft.com/aem it logs you out of https://ecocitycraft.com and vice versa.
Hi @andrewkm, as @Tracy Perry alluded to this logout issue is due to cookies.

The cookie settings in XF by default have the _xf prefix which will affect all XF installations on the same domain..

You need to edit this setting in library/config.php for one of the XF installations to change the prefix so the cookies don't clash:
$config['cookie']['prefix'] - default: 'xf_'
All cookies set by XenForo will have this prefix. This can be changed if you have multiple XenForo installations on the same domain.
https://xenforo.com/help/config-php-options/
 
Top