[TH] User Edit on Front End

[TH] User Edit on Front End 1.0.5

No permission to download

Jon W

Well-known member
Waindigo submitted a new resource:

User Edit on Front End by Waindigo - Adds a permission and interface for editing members on the front end of your site

This add-on allow your members with permission to edit other members profiles on the front end of your site:​
  • Works for basic information, custom fields and regular fields;
  • Allows you to edit a members avatar;
  • New permission to restrict access to this feature;
  • Options included to manage what can be edited using this...
Read more about this resource...
 
Last edited:

squirrly

Active member
Moderators aren't able to edit fields unless they're also marked for users to be able to edit. Combinations that aren't allowing moderators to edit through the front end/edit full profile link:

Screenshot 2014-08-15 00.34.03.png Screenshot 2014-08-15 00.32.58.png Screenshot 2014-08-15 00.33.42.png

This one DOES allow moderator edits:
Screenshot 2014-08-15 00.34.58.png

Bug?
 

Attachments

squirrly

Active member
Ok, that kind of solves the issue for ME, as an admin, super mod, etc. (it lets me edit everything, but it's still not following the setup of the fields above - the moderator setting is useless). But my regular mods, it's like the "Edit Full User Profile" permission on the Moderator setup tab for each of them is completely useless.

None of my mods get "Edit Full User Profile" in their Moderator Tools dropdown. Only "Edit" which corresponds with basic. And, only the sub-account custom fields are showing up, as the other custom fields are on the "Additional Contact" screen.

Looks like the only way I can make this work is to add all these people as admins with "manage users", which REALLY defeats the purpose.
 

Jon W

Well-known member
Ok, that kind of solves the issue for ME, as an admin, super mod, etc. (it lets me edit everything, but it's still not following the setup of the fields above - the moderator setting is useless). But my regular mods, it's like the "Edit Full User Profile" permission on the Moderator setup tab for each of them is completely useless.

None of my mods get "Edit Full User Profile" in their Moderator Tools dropdown. Only "Edit" which corresponds with basic. And, only the sub-account custom fields are showing up, as the other custom fields are on the "Additional Contact" screen.

Looks like the only way I can make this work is to add all these people as admins with "manage users", which REALLY defeats the purpose.
I'm a tad confused, what is wrong with assigning the Edit Full User permissions to your mods, is this not functioning correctly?
 

squirrly

Active member
I'm a tad confused, what is wrong with assigning the Edit Full User permissions to your mods, is this not functioning correctly?
Correct. It is not working AT ALL. Toggling that permission on/off has zero effect on anything. That's what I would prefer to do, but it doesn't work.
 

Jon W

Well-known member
Correct. It is not working AT ALL. Toggling that permission on/off has zero effect on anything. That's what I would prefer to do, but it doesn't work.
Have you set the 'allowed user groups' option in the add-on options?
 

squirrly

Active member
Yes, it is enabled. If I add Admin as noted above, it works. When I take Admin away, I can get 'edit full profile' in the moderator tools dropdown, but then I get an error when I actually click on it - You do not have permission to view this page or perform this action.

I'm at a loss. I've tried everything.
 

Jon W

Well-known member
@squirrly Can you send me a PM with some log-in details for your site and I'll have a look into it for you. Thanks
 
Last edited:
Did you find anything, as I think I may be having a similar issue.....

With Options -> Allow Editing of all Custom Fields checked, all custom fields are visible, and editable by moderators.
With Options -> Allow Editing of all Custom Fields blank , only custom fields both (User editable AND Moderator editable) are editable via the front end.


waindigo_custom_fields_edit_usereditfrontend
<xen:foreach loop="$customFields" value="$field">
<xen:if is="{$field.isEditable} || {$xenOptions.waindigo_userEditFrontEnd_overrideFieldsEditable}">
<xen:include template="custom_field_edit" />
</xen:if>
</xen:foreach>


Is $field.isEditable correct, or should it be $field.moderator_editable ?

Alan
 

Minterwute

New member
Using this addon together with Sub-accounts, I've had user (registered users, specifically) run into the issue that they get a permission error when trying to edit profile fields on their sub-accounts. Notably, they can access the edit page, but trying to save changes will result in an error. I've checked and double-checked that everything is configured correctly, and have eventually traced the bug to its source.

A little debugging led me to function canEditFullUser() defined in Waindigo_UserEditFrontEnd_Extend_XenForo_Model_User, where the check for sub-accounts is made.
Code:
    // Sub-account parents can edit their children.
    if ($this->_subAccountsCheck() && $options->waindigo_userEditFrontEnd_subaccountsEdit &&
  $viewingUser['user_id'] == $user['subaccount_parent_user_id']) {
        return true;
    }
Specifically the issue is the comparison at $viewingUser['user_id'] == $user['subaccount_parent_user_id'], because $user and $viewingUser always refer to the same user record, and thus, will always produce false.

Basically, one of those silly bugs everyone always seems to end up with. Thanks for your software and your support; it's excellent stuff!
 
Top