[TH] Infusionsoft API [Deleted]

Potential feature not working as intended.

When user contact details are being synced into InfusionSoft, they aren't showing up as "marketable". You have to manually update them one-by-one to send newsletters and broadcast-type emails.

What I see in the contact's page in InfusionSoft for every synced user:

Manage the Opt Status of xxx@xxx.com
View Status History
Current Status: Non-marketable
There is no evidence that this person has consented to receive marketing.

You will be able to send individual emails, but broadcast and follow-up sequence emails will not be delivered.

You can:
Indicate that you have permission to market to this address...
Manually opt-out this address...

Settings
  • Currently only syncing contacts who have opted in using the checkbox on registration / their account details page.
Resolution

There are some write-ups that I found while searching on Google. Would this help out? http://community.infusionsoft.com/showthread.php/12134-Non-marketable-Email-Status

Another potential problem:
I have custom fields set up to import their last login date (date), primary usergroup (text), and secondary usergroups (text). None of these custom fields are syncing into InfusionSoft.

Conclusion
Please let me know if you would like login to my website and/or InfusionSoft account to look into this. Overall I am happy with the plugin so far once these items are fixed. Thanks, @Jon W!
 

Jon W

Well-known member
Potential feature not working as intended.

When user contact details are being synced into InfusionSoft, they aren't showing up as "marketable". You have to manually update them one-by-one to send newsletters and broadcast-type emails.

What I see in the contact's page in InfusionSoft for every synced user:

Manage the Opt Status of xxx@xxx.com
View Status History
Current Status: Non-marketable
There is no evidence that this person has consented to receive marketing.

You will be able to send individual emails, but broadcast and follow-up sequence emails will not be delivered.

You can:
Indicate that you have permission to market to this address...
Manually opt-out this address...

Settings
  • Currently only syncing contacts who have opted in using the checkbox on registration / their account details page.
Resolution

There are some write-ups that I found while searching on Google. Would this help out? http://community.infusionsoft.com/showthread.php/12134-Non-marketable-Email-Status

Another potential problem:
I have custom fields set up to import their last login date (date), primary usergroup (text), and secondary usergroups (text). None of these custom fields are syncing into InfusionSoft.

Conclusion
Please let me know if you would like login to my website and/or InfusionSoft account to look into this. Overall I am happy with the plugin so far once these items are fixed. Thanks, @Jon W!
I am aware of the "opt status" (I think you pointed out) and I coded it so that it should be opting users in when they check the marketing field. It seems this is not happening, so I will need access to your website and Infusionsoft account. If you could send me those details by PM, that would be much appreciated.

I'm away next week, so I may not have a chance to look at this before I go away. I'll try and look into it as soon as I can though.
 
I am aware of the "opt status" (I think you pointed out) and I coded it so that it should be opting users in when they check the marketing field. It seems this is not happening, so I will need access to your website and Infusionsoft account. If you could send me those details by PM, that would be much appreciated.

I'm away next week, so I may not have a chance to look at this before I go away. I'll try and look into it as soon as I can though.

Thank you for your response. Messaged you username / password to both xenForo and InfusionSoft on https://waindigo.org/
 

mrrobbo

Member
hi - just installed the plugin and had a few questions

1. I want to sync my contacts from Infusionsoft with a specific tag, looks easy enough - however once I do this I'm wondering what happens for the end user - will they receive login information/passwords etc. Will they be pushed to a registration page???
 

casmccullough

New member
Hi Jon, Does this add-on enable a login to be set automatically from infusionsoft? I am setting up a new membership site and am trying to figure out what add-ons I need. The user journey is:

Sign up to subscription via landing page on WordPress site
Invoiced through IS
Put into purchase funnel and given logins
Login to site

I'd like to be able to have lapsed users automatically tagged as lapsed on IS when they cancel their membership and removed from the forum. Is all this possible with your plugin or will I need other add ons?

Would love your advice.

cheers,

Cas
 

Trajan King

New member
Hi Jon, Does this add-on enable a login to be set automatically from infusionsoft? I am setting up a new membership site and am trying to figure out what add-ons I need. The user journey is:

Sign up to subscription via landing page on WordPress site
Invoiced through IS
Put into purchase funnel and given logins
Login to site

I'd like to be able to have lapsed users automatically tagged as lapsed on IS when they cancel their membership and removed from the forum. Is all this possible with your plugin or will I need other add ons?

Would love your advice.

cheers,

Cas


@casmccullough , I had the same question. Did you get an answer? @Jon W
 
I'm the person (NFA_LLC is my alt account) who paid for an opt-in on the registration page and user settings, in which ONLY users who opt-in should be imported into InfusionSoft. I also replied and had a conversation with @Jon W about over half of the imported InfusionSoft contacts showing as "non-marketable", so whenever I send a broadcast, thousands of people don't ever get it.

Jon W said it was working as intended because the people who show up as "non-marketable" in Infusionsoft never checked the opt-in box. However, I don't think this is as-intended because if they never opted in during registration or on their profile, they should have never been imported into InfusionSoft to begin with.

Would you or @Jon W please instruct on what to do? Would appreciate it, because basically my InfusionSoft is clogged up with people who never opted in.

TL;DR - "Export opted in users only" option isn't working as intended because it is also importing users who haven't opted in.

Edit: Paging @Audentio Design.
 
Last edited:

gtrgriff3

Member
I tried installing this and I noticed that after connecting with IS the first time, not all tags were brought over. Things just don't seem to be working very well and I got an error that I can't find now to re-paste. I tried going to waindigo.org but I can't see that there is any help there.

It's a shame, this looks like just what I need but it doesn't appear to be very robust. I'd be happy to pay for the license if it worked.
 

gtrgriff3

Member
Here is the error, I was able to reproduce it using the "sync recent contacts"

Mysqli statement execute error : Data too long for column 'infusionsoft_contact_group_ids_waindigo' at row 1

  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 632
  4. Zend_Db_Adapter_Abstract->update() in XenForo/DataWriter.php at line 1654
  5. XenForo_DataWriter->_update() in XenForo/DataWriter.php at line 1623
  6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1419
  7. XenForo_DataWriter->save() in Waindigo/InfusionsoftApi/Model/InfusionsoftApi/DataService/Contact.php at line 339
  8. Waindigo_InfusionsoftApi_Model_InfusionsoftApi_DataService_Contact->pullContact() in Waindigo/InfusionsoftApi/Model/InfusionsoftApi/DataService/Contact.php at line 222
  9. Waindigo_InfusionsoftApi_Model_InfusionsoftApi_DataService_Contact->pullContacts() in Waindigo/InfusionsoftApi/CronEntry/SyncRecentlyUpdated.php at line 14
  10. Waindigo_InfusionsoftApi_CronEntry_SyncRecentlyUpdated::pullContacts()
  11. call_user_func() in XenForo/Model/Cron.php at line 357
  12. XenForo_Model_Cron->runEntry() in XenForo/ControllerAdmin/Cron.php at line 213
  13. XenForo_ControllerAdmin_Cron->actionRun() in XenForo/FrontController.php at line 351
  14. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  15. XenForo_FrontController->run() in /home/bluesgui/public_html/xenforo/admin.php at line 13
 

ActiveMgmt

Member
Hi, Thank you so much for building this add-on.

I'm having a bit of difficulty with assigning new user pulled from Infusionsoft into a User Group in Xenforo. I have custom field (text field) set up for Primary and Secondary User Group. Setting the value of these custom fields in Infusionsoft does not seem to do anything. New user pulled from Infusionsoft is set to the default "Registered" User Group. Does anyone have any idea on how to make this work? We have different membership level so we need to set this up automatically when people in Infusionsoft. Thank you in advance.

I am also getting these two repeating errors on the Server Error Log.
  1. Undefined offset: 04 minutes ago - library/Waindigo/InfusionsoftApi/Option/DataFormFields.php:38
  2. Array to string conversion4 minutes ago - library/Waindigo/InfusionsoftApi/Option/DataFormFields.php:40
Any idea what they might be? Fixes?
 
Last edited:

JohnLogar

Active member
Your add-on is working for me except for one thing.... imported users are not being added to user groups based on their tags. So far I only have two tags in IF, one for registered users and one for mastermind group. When they optin IF assigns them both tags.

In the API add-on I have the assigned the appropriate tag to each of those two groups. However, users are only being added as registered users and not assigned to the tagged user group. Even if I remove the registered user tag they are still not added to the mastermind even though they are tagged in IF and the tag has been assigned to that user group via the add-on.

Also, I would like them to create a username and password via the IF form. The username is being pulled over but not the password. Is there anyway to make that happen via a custom field?
 

ActiveMgmt

Member
I know this Add-on is no longer supported so this is a long shot to see if I can get help to fix this.

I recently upgraded to Xenforo 1.5.12 then the Infusionsoft add-on stops working.

Here is the error I get when Infusionsoft tries to push a new user into Xenforo

Fatal Error: syntax error, unexpected '}'
A moment ago - library/Zend/Http/Client/Adapter/Socket.php:546

I now have to manually monitor for new members then add them to Xenforo myself - not at all practical.

I have contacted ThemeHouse (The people who took over Waindigo), they don't seem to even care about this product any more. They simply said to seek help in the community forum. Jon W, if you are still receiving this message at all, we are keen to have your input and help fix this.

If anyone know how to fix this too, please help. We will pay for your help.
 

Mike C

Well-known member
I know this Add-on is no longer supported so this is a long shot to see if I can get help to fix this.

I recently upgraded to Xenforo 1.5.12 then the Infusionsoft add-on stops working.

Here is the error I get when Infusionsoft tries to push a new user into Xenforo

Fatal Error: syntax error, unexpected '}'
A moment ago - library/Zend/Http/Client/Adapter/Socket.php:546

I now have to manually monitor for new members then add them to Xenforo myself - not at all practical.

I have contacted ThemeHouse (The people who took over Waindigo), they don't seem to even care about this product any more. They simply said to seek help in the community forum. Jon W, if you are still receiving this message at all, we are keen to have your input and help fix this.

If anyone know how to fix this too, please help. We will pay for your help.
It's not that we do not care it's just that we don't have anyone who knows the code, except Jon, and he left the market. We are happy to fix the issue but we'd need to get you an estimate. If you end up not finding someone or prefer that we do it feel free to message me. :)
 
Top