XF 2.2 template modifications dont match sometimes

Iggy

Well-known member
hello,
getting in some better practices by making all our hacks as official template modifications.....

ran into some issues with a couple i dont understand tho......i dont get proper matches for all styles, even tho the code is exactly pasted...

i did at least notice that spacing matters so im grabbing the code directly from the templates i want to edit.....they should be the same tho from style to style as the raw templates are not edited at all....

this last one i did, it only applied it to the "master style"....

cant imagine why or how to work around that.....anyone help please?

thank you
 

Iggy

Well-known member
oh you know....a little hack here or there for some basic functionality....

i suppose master style only is fine, i mean, that works, but i dont understand the logic why some apply to 5 styles or such and some just one or 3 or such...i know of course edits to a custom style will not apply to the master and will instead apply to a list, just seems like theres something more going on....

maybe its all fine idk.....also that last one i did tricked me to thinking it didnt work when it did lol so main problem is gone at least....still a little confusing tho.

regards
 

Brogan

XenForo moderator
Staff member
Template modifications won't match if there are other modifications by third party styles and add-ons, which are applied before yours.
 

Iggy

Well-known member
Template modifications won't match if there are other modifications by third party styles and add-ons, which are applied before yours.
its not so much that they "dont match"(center column), they just arent recognized at all......in any of the 3 columns....

i did one test changing the exec order, maybe i didnt go deep enough. kind of didnt seem like the problem tho...just curious really this one seemed strange to me

thank you
 
Top