TaigaChat Pro - Realtime chat/shoutbox

TaigaChat Pro - Realtime chat/shoutbox [Paid] 1.4.7

No permission to buy (£25.00)

grantus

Active member
Is there a way to set the default text color for when people post? I just changed my forum style to a darker one, so it was black text before but now I want it to be white. What would I change? Thanks.
 

Harkin

New member
Hello.

I wasn't able to find this on the past 5-6 pages so I hope it wasn't mentioned earlier - the text modification buttons do not appear next to the chat box (the buttons for Bold, Italic, Strikethrough, IMG, and URL). They just appear white.

a0v1c2.png


The CSS code in dark_taigachat.css shows:

Code:
.taigachat_bbcode span.mceIcon, .taigachat_bbcode img.mceIcon {display:block; width:20px; height:20px}
.taigachat_bbcode .mceIcon {background:url(styles/dark/icons.png; ) no-repeat 20px 20px}
.taigachat_bbcode span.mce_bold {background-position:0 0}
.taigachat_bbcode span.mce_italic {background-position:-60px 0 }
.taigachat_bbcode span.mce_underline {background-position:-140px 0}
.taigachat_bbcode span.mce_strikethrough {background-position:-120px 0}
.taigachat_bbcode span.mce_link {background-position:-500px 0}
.taigachat_bbcode span.mce_image {background-position:-380px 0}

The image does show up when I navigate to its URL as per the CSS code above, so it's definitely not a corrupt file.

Any help would be much appreciated!
 

Morhaus

Member
I get an error when I try to install the add-on.

Code:
The files associated with this add-on could not be found. Please upload them and try again.

All the required files are present on the server.

I'm using xenforo 1.3.1. Is this addon really compatible with 1.3 ?
 

rdn

Well-known member
I get an error when I try to install the add-on.

Code:
The files associated with this add-on could not be found. Please upload them and try again.

All the required files are present on the server.

I'm using xenforo 1.3.1. Is this addon really compatible with 1.3 ?
Yes it's compatible, but you didn't upload the files correctly.
 

Luke F

Well-known member
I get an error when I try to install the add-on.

Code:
The files associated with this add-on could not be found. Please upload them and try again.

All the required files are present on the server.

I'm using xenforo 1.3.1. Is this addon really compatible with 1.3 ?

Yes, 1.3 is fully supported

Make sure you are uploading the contents of the 'upload' folder, rather than the upload folder itself. You should end up with /library/Dark alongside /library/XenForo
 

Morhaus

Member
Yes, 1.3 is fully supported

Make sure you are uploading the contents of the 'upload' folder, rather than the upload folder itself. You should end up with /library/Dark alongside /library/XenForo

Thanks for the quick reply. I apologise, this was a mistake on my part. I had uploaded the files to an non-deployed version of the forum. The add-on works perfectly fine on 1.3.1.
 

Arkshine

Active member
I've this flooding my error logs:

Code:
Journal des erreurs serveur
Info concernant l'erreur
ErrorException: Fatal Error: Call to a member function getName() on a non-object - library/Dark/TaigaChat/CronEntry/CleanUp.php:13
Généré par: Compte inconnu, Aujourd'hui à 07:29
Trace de la pile
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Etat de la requête
array(3) {
  ["url"] => string(29) "http://cs-amx.fr/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(9) "/membres/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}

Latest XF, TaigaChat 1.2.0. Not sure why.
 

Claudio

Well-known member
Luke, I've installed this addon but the text I enter isn't sent no matter if I press enter or the > button. This happens with a custom style but I have no problems with the normal use of the forum so there might be a conflict with your addon and a modification made to my style.

Could you please start a conversation with me so I can send you the login details?

Thanks!
 

GeorgeS

Member
Hello,


there are two problems that I face at the moment:

- in the Defiance style, the text color of the shoutbox messages is almost impossible to read, so I would really love to find a way to customize that color (as the color picker seems only to work for the entry field);
- some users would like an option to minimize/remove the chatbox, but I couldn't figure out a way to do so.
 

Harkin

New member
I'd suggest you inspect the button elements in your browser to find out which CSS rule is actually taking precedence.

I figured it out after finally getting some time to work on it. The problem actually resided in the CSS code that I posted..surprised nobody noticed, but then again I didn't either :)

Code:
.taigachat_bbcode .mceIcon {background:url(styles/dark/icons.png; ) no-repeat 20px 20px}

Damn semicolons....
 
Top