Resource icon

Tags on Thread List 0.2

No permission to download

Freelancer

Well-known member
Great feature, however it is not installing?

View attachment 148352

An exception occurred: addm.css - Line 30: Invalid math expression in /***** /*****/public_html/*****. com/forums/library/XenForo/Template/Compiler.php on line 991

  1. XenForo_Template_Compiler->getNewCompilerException() in XenForo/Template/Compiler/Function/Calc.php at line 189
  2. XenForo_Template_Compiler_Function_Calc->_parseMathExpression() in XenForo/Template/Compiler/Function/Calc.php at line 55
  3. XenForo_Template_Compiler_Function_Calc->compile() in XenForo/Template/Compiler.php at line 700
  4. XenForo_Template_Compiler->compileFunction() in XenForo/Template/Compiler.php at line 576
  5. XenForo_Template_Compiler->compileSegment() in XenForo/Template/Compiler.php at line 509
  6. XenForo_Template_Compiler->compileSegments() in XenForo/Template/Compiler.php at line 372
  7. XenForo_Template_Compiler->compileParsed() in XenForo/Model/Template.php at line 1601
  8. XenForo_Model_Template->compileAndInsertParsedTemplate() in XenForo/Model/Template.php at line 1379
  9. XenForo_Model_Template->compileTemplateInStyleTree() in XenForo/Model/Template.php at line 1329
  10. XenForo_Model_Template->compileNamedTemplateInStyleTree() in XenForo/Model/Template.php at line 1268
  11. XenForo_Model_Template->compileAllTemplates() in XenForo/Deferred/Template.php at line 36
  12. XenForo_Deferred_Template->execute() in XenForo/Deferred/Atomic.php at line 66
  13. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 295
  14. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 429
  15. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 374
  16. XenForo_Model_Deferred->run() in XenForo/ViewRenderer/Abstract.php at line 352
  17. XenForo_ViewRenderer_Abstract::hasManualDeferredToRun() in XenForo/ViewRenderer/HtmlAdmin.php at line 130
  18. XenForo_ViewRenderer_HtmlAdmin->renderContainer() in XenForo/FrontController.php at line 637
  19. XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
  20. XenForo_FrontController->run() in /*****/*****/public_html/*****. com/forums/admin.php at line 13
That is an Audentio Donation Manager (ADDM) Error...
 

Sam F

Active member
Installed Tags on Thread List 0.1,
went to look at my tags on the right side of the thread index and non are showing up?

Any suggestions on what to check?
 

Sam F

Active member
Installed Tags on Thread update
went to look at my tags on the right side of the thread index and non are showing up?

Any suggestions on what to check?
 
Installed Tags on Thread update
went to look at my tags on the right side of the thread index and non are showing up?

Any suggestions on what to check?
The first version of the plugin used a horrible practice of overwriting master style. You now need to go to http://yourforumurl.com/install/ and hit "Rebuild master data". Sorry about that. The update (v0.2) uses properly template modification which will not have that problem.
 

Sam F

Active member

Kyros

Member
I know this is Unmaintained but this doesn't work on my site that uses UI.X. It works on the default theme so I'm pretty sure its UI.X. Would love to hear if anyone has ideas about what I can do, it would be appreciated, figured it was worth a shot!
 
All this addon is really doing is to add the following code in the template:
Code:
<xen:if is="({$thread.tagsList} AND {$xenOptions.enableTagging})">
    <ul class="tagList" style="float: right;">
        <xen:foreach loop="$thread.tagsList" value="$tag">
            <li><a href="{xen:link tags, $tag}" class="tag"><span class="arrow"></span>{$tag.tag}</a></li>
        </xen:foreach>
    </ul>
</xen:if>
Thus, you can try to add that in XF2 or by editing the UI.X templates. It probably doesn't work by default with UI.X because the style is overriding the default template and the search&replace doesn't find what it wants to replace.
 

Kyros

Member
All this addon is really doing is to add the following code in the template:
Code:
<xen:if is="({$thread.tagsList} AND {$xenOptions.enableTagging})">
    <ul class="tagList" style="float: right;">
        <xen:foreach loop="$thread.tagsList" value="$tag">
            <li><a href="{xen:link tags, $tag}" class="tag"><span class="arrow"></span>{$tag.tag}</a></li>
        </xen:foreach>
    </ul>
</xen:if>
Thus, you can try to add that in XF2 or by editing the UI.X templates. It probably doesn't work by default with UI.X because the style is overriding the default template and the search&replace doesn't find what it wants to replace.
Thank you! Wasn't expecting a response really so I'm pleasantly surprised.
 

Kyros

Member
All this addon is really doing is to add the following code in the template:
Code:
<xen:if is="({$thread.tagsList} AND {$xenOptions.enableTagging})">
    <ul class="tagList" style="float: right;">
        <xen:foreach loop="$thread.tagsList" value="$tag">
            <li><a href="{xen:link tags, $tag}" class="tag"><span class="arrow"></span>{$tag.tag}</a></li>
        </xen:foreach>
    </ul>
</xen:if>
Thus, you can try to add that in XF2 or by editing the UI.X templates. It probably doesn't work by default with UI.X because the style is overriding the default template and the search&replace doesn't find what it wants to replace.
Sorry to bother you again, what template exactly should I put this into? To make it clear I am on XF 1.5, actually, not XF2. Thank you once again!
 
Top