1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Suddenly auto log out

Discussion in 'Troubleshooting and Problems' started by tihasz, Dec 17, 2015.

  1. tihasz

    tihasz Member


    we are using XenForo for months and it works great! But since last week, i noticed something weird. It logs the users out after a short time (a hour or so). We didn't touch anything on the back-end or on the server.

    Did this happen to anyone else?

    Could this be some side-effect of a hacker attack or? Really no ideas what could caused it and how to fix it.

  2. tihasz

    tihasz Member

    btw, just noticed that i posted in wrong forum, the XF version is 1.5.0
  3. Misayuki

    Misayuki New Member

    I don't think it is a hacking attempt or anything.

    If it is happening after an hour, I could be wrong, but it may be simply this

    Apparently if you are inactive for an our, it will just log you out after an hour or so.

    However on my XF 1.5 installation, I notice it does this even if I am active and less than an hour. not often but occasionally it'll just randomly log me out when I click a link(and some of my users reported it) but while annoying, it doesn't happen enough for me to care about complaining lol.
    tihasz likes this.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If the member checks "Stay logged in" then they should be auto logged back in.

    If this is no longer working and the behaviour has changed without you making any changes, then you may want to contact your host and ask them what has changed on the server.
  5. tihasz

    tihasz Member

    Is there a way I could code that in, so that I set for every user the "Stay logged In" ?
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You would have to edit the template.
  7. tihasz

    tihasz Member

    Which one?
  8. Brogan

    Brogan XenForo Moderator Staff Member

Share This Page