• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Staying Logged In

#1
I am running the latest version of 1.4 using HTTPS at Skywarn Forum where I have it set to redirect www. to non-www. via my web hosting control panel (which is DreamHost). My forum was recently merged to XF 1.4 from IPB. I also merged a vb 3.8 forum into it as well. Some users say they always remain logged in. However, I and other have to login each time we close the window/tab and visit the forum again later on. I have two other XF 1.4 forums (non-https) that keep me logged in.

Any thoughts, ideas, suggestions? Thanks in advance! :)
 

Neal

Well-known member
#3
@Shawn Gossman

I use this in my .htaccess to force it to use https without www (Otherwise people can go to www or http and have to login again, etc):

Code:
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://skywarnforum.com/$1 [R,L]
 
#4
I'm getting this error when trying to access your site.

View attachment 112174
That is odd. First time I have heard of that error displaying. I get no errors at all!

@Shawn Gossman

I use this in my .htaccess to force it to use https without www (Otherwise people can go to www or http and have to login again, etc):

Code:
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://skywarnforum.com/$1 [R,L]
Thanks, I will give that a shot!
 

Neal

Well-known member
#6
Did you remove the changes you made in your hosting control panel if using the .htaccess file edit above? I'm assuming you have also changed the board url in XenForo settings to https?
 
#7
I haven't messed with the hosting control panel settings at all. Should I change it back to www? I have added https to the XF panel, yes. On the htaccess, do I need to put the code you provided in a bracketed tags?
 

Neal

Well-known member
#8
I haven't messed with the hosting control panel settings at all. Should I change it back to www? I have added https to the XF panel, yes. On the htaccess, do I need to put the code you provided in a bracketed tags?
You can use www or not, it's your choice. I prefer without www which is why I have it set that way in the .htaccess, and in my XenForo admin control panel as https:// mydomain.com (Space added as it auto links! :) )

Open the .htaccess file in Notepad++ and just paste the code below the "RewriteEngine On" and before "# If you are...." as it is:

Code:
<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://skywarnforum.com/$1 [R,L]

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite.........
 
#9
You can use www or not, it's your choice. I prefer without www which is why I have it set that way in the .htaccess, and in my XenForo admin control panel as https:// mydomain.com (Space added as it auto links! :) )

Open the .htaccess file in Notepad++ and just paste the code below the "RewriteEngine On" and before "# If you are...." as it is:

Code:
<IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://skywarnforum.com/$1 [R,L]

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite.........
You the man, Neal! :D Thank you thank you bubba - works perfectly! :)