1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Start converstion not working

Discussion in 'Troubleshooting and Problems' started by herocus, Dec 14, 2014.

  1. herocus

    herocus Member

    Hi
    I just today realized that when I'm trying to make conversation to a member, it shows error:

    What could be wrong? I have confirmed to the member that he has permission in privacy option.

    start-conversation-error.jpg
     
  2. Amaury

    Amaury Well-Known Member

    Check your user group permissions.
     
  3. herocus

    herocus Member

    Hi Maru, thanks for your advise
    I have checked to Allow to everything... but still have the same problem.

    I don't understand, I was working before... just yesterday this happened...
     
  4. Amaury

    Amaury Well-Known Member

    Did you do anything since yesterday, such as install an add-on?
     
  5. herocus

    herocus Member

    as far as I remember, I only install sonnb-xengallery.
    However, I have my friend setup as admin does not have problem with 'start conversation'
    He can message me and other member can message me through start conversation... but fror some reason I do not have permission and get the error above.
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Make sure that the number of participants is set higher than 0 in the registered (if you allow all registered users to do it) or higher than 1 in your Admin user group that you are a member of.

    Depending on how you have implemented your user groups, odds are that you have something other than registered as your primary (if you already have it so that registered has more than 0 participants)... and you have your primary as something like Administrator which is set at 0 particpants.
     
  7. herocus

    herocus Member

    Hi Tracy,
    Thanks for you help.
    Where should I set the number of participants? is that in User Group Permissin (attached picture) ?
     

    Attached Files:

  8. Tracy Perry

    Tracy Perry Well-Known Member

    You have it set as unlimited... so that should be working - unless you are a member of a group that has "never" set for conversations. If you want, you can start a convo with me with ACP access and I can take a quick look at it and see if I can figure it out. Shouldn't be anything that major.
     
  9. herocus

    herocus Member

    Hi @Tracy Perry
    I've Convo you the ACP access.
    Thanks for your help
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    Think I found the problem (one amongst several).
    You had a secondary group membership for the user you sent me of Newly_registered. In that group you had this set

    Screen Shot 2014-12-15 at 3.13.12 AM.png

    As you can see... you set Never... which over-rode all other settings. I removed you from that group and it should work now (further, I set the group to use the Not Set (No) setting).

    Additionally, you did not have the account assigned with the normal Registered as primary and using the secondary for all other groups (which is something I mentioned in an earlier post). That also has been fixed for that account. You need to review @Brogan's most excellent resource on implementing permissions in XenForo then make adjustments to your current setup to work within the suggested guidelines.
     
    herocus likes this.
  11. herocus

    herocus Member

    Hi @Tracy Perry

    Thanks very much for you help, as I'm actually quite new with this.
    And thanks for the link for Brogan's explanation about.

    It works like a charms now... I do appreciate your help.
     
  12. Tracy Perry

    Tracy Perry Well-Known Member

    No problem... was glad I could help. If that was your normal account you may want to change the password. I'll leave the conversation and once you leave it then neither one of us can see the one you gave me again.
     
  13. herocus

    herocus Member

    Hi Tracy
    Thanks for the heads up about the password.
     

Share This Page