• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 "start a conversation" option missing on members profile pages

#1
I am very new to Xenforo and seem to have a new issue every day when logging into my forum. I so love being sidetracked with what ends up being simple solutions to my annoying problems. (y) (not really)

Anyway, today's issue is that I do not have the "start a conversation" option for members when I go to their profile page. My moderator does though.

Any help would be greatly appreciated and thanks very much in advance.

jackjac.JPG mben does not have start conversation for jackjack.jpg
 
#3
Check your permissions and, in addition, make sure everyone's primary user group is registered, with staff user groups being secondary.
Thanks, Maru!

I did have all my permissions set to "allow" for all permissions.

After going and making the change for myself from user group "super moderators" with secondary being "none" to user group "registered" and secondary being "super moderators", I now have the start a conversation option on member's profile pages.
What's strange though is my mod was set to user group "moderating" and secondary was "none" but she had the conversation option. I went ahead and changed hers to what you suggested and she still has the option for conversations.

All's well so far and again, thank you very much!
 

Amaury

Well-known member
#4
Glad you got it sorted.

On XenForo, all users' primary user groups should be Registered. There you'll set all the permissions you want your users to have. Then for staff user groups, all you have to do is set additional permissions you want them to have (e.g., permanently delete posts) that are revoked from your Registered user group.

These help articles should help:
https://xenforo.com/help/user-groups/
https://xenforo.com/help/permissions/
 
#5
Thanks for the articles, Maru. I do need to read up on them because after making the changes, I lost ability to mod the forum posts. I went ahead and made myself admin, got all my powers back including being able to start conversations. I'll leave it like that until I can read the articles and figure out why the "super mod" group is not working right for me.