XF 1.5 Spam accounts and spam bots

Pilgrim

Member
Hey all,

I am having huge issues with spam accounts/bots that keep posting crap links all over the my gaming community forums (http://www.mystical-awakening.net). I have followed the steps here: https://xenforo.com/community/resources/block-spam-completely-with-no-addons.4065/ I am using recaptcha (checked it with a test account and you need to fill it in for registration... I am slowly getting to a point where I want to dump Xenforo because of all of this and go back to another option for my gaming community.

Any help, advice, things I missed?

Thanks in advance
 

Martok

Well-known member
What are your Spam management settings in the ACP?
Within this, have you got a Project Honeypot key and an Akismet Key?
It's probably worth sharing all of your settings via a screenshot.

I'd also suggest you switch to Question & Answer CAPTCHA and create several questions that only humans who are likely to use your community will be able to answer.
 

Martok

Well-known member
I'd recommend you remove or amend those screenshots as you are showing the actual keys used which you shouldn't be sharing.

You haven't included the Stop Forum Spam settings (the ones right at the top).

Why have you reduced the Maximum Messages to Check for Spam to 2? The default is 5. It'd probably be better to check more than less.

Can you confirm that the Bypass Spam Check permission for the Registered User Group (which should be the default user group for everyone including new members) is set to Not Set (No)?

I'd also suggest you switch to Question & Answer CAPTCHA and create several questions that only humans who are likely to use your community will be able to answer.
 
Top