sonnb - Stop Spam Here

sonnb - Stop Spam Here [Paid] 2.0.0 RC 4

No permission to buy ($15.00)

sonnb

Well-known member
sonnb updated sonnb - Stop Spam Here with a new update entry:

Version 1.2.4, 08th April 2013

Change Logs:
  • Major code changes, less of codes, faster of speed. This also means it would stop spammer from posting valid message then edit again with invalid messages.
  • Remove dependences on TMS addon. Now it would show in template without TMS and you of course do not have to manually edit the templates
  • Added 2 more hidden fields with 2 different type to trap auto bot.
  • Fixed error when moving thread on spam deletion.
  • Fixed previously not checking if user is a guest...

Read the rest of this update entry...
 

Volion

Active member
Recent update is throwing longtime members posts into the mod queue, even though they are well past the minimum post requirement or registered time set in the SFP options. This is getting annoying to the point of disabling/uninstalling.
 

sonnb

Well-known member
Recent update is throwing longtime members posts into the mod queue, even though they are well past the minimum post requirement or registered time set in the SFP options. This is getting annoying to the point of disabling/uninstalling.
Confirmed and fixed. Thanks.
 

high1976

Active member
is there any known problem with 1.2.5 and logging? Registration block-logs are not generated anymore, just new posts with links show up in logs.
 

sonnb

Well-known member
sonnb updated sonnb - Stop Spam Here with a new update entry:

Version 1.2.6, 16th April 2013

- Add new limitation for registration times per IP per hour/day/week/month. That allow you to limit/prevent specific spammers/bots to bulk registering on your forum.
- Fix issue when a Mod approves a message that contains filtered words/links/Akismet by changing that message but keep that filtered content remains and that Mod also does not have bypass permission
- Fix issue that logs for registration were not being saved.

Read the rest of this update entry...
 

Silvan

Member
I've had to uninstall the add on, as it caused an error. Users were able to register, but once they've filled out their form and submitted it, they were shown an error page (they were registered, however a lot of users didn't return as they were thrown out of the site).

Any idea why this is happening? I removed the entire add-on and reinstalled it, but that didn't sort the issue. It seems to have happened when Xenforo was upgraded to version 1.14.

Fatal error: Call to undefined method DateTime::sub() in/var/sites/w/wearepopslags.com/public_html/forum/library/sonnbStopSpamHere/Model/SSH.phpon line 211
 

sonnb

Well-known member
I've had to uninstall the add on, as it caused an error. Users were able to register, but once they've filled out their form and submitted it, they were shown an error page (they were registered, however a lot of users didn't return as they were thrown out of the site).

Any idea why this is happening? I removed the entire add-on and reinstalled it, but that didn't sort the issue. It seems to have happened when Xenforo was upgraded to version 1.14.
It is not because of XF 1.1.4. It is because of I am using new function to get date in the new update. What is your PHP version? This function is available since 5.3.0. It is maybe because you are using older PHP version.
 

Silvan

Member
It is not because of XF 1.1.4. It is because of I am using new function to get date in the new update. What is your PHP version? This function is available since 5.3.0. It is maybe because you are using older PHP version.

Ah, you're absolutely right! My site was running on PHP 5.2 hence the error. Just upgraded it to 5.3 and it's running smoothly. Thanks for the tip.
 

cmeinck

Well-known member
Upon upgrading to the latest version, with the fix, no one can post to the forum. It says to check the javascript server logs, but I don't see anything in the logs. Can I downgrade? I hate to delete the plug-in, since I've got all sorts of settings in there.
 
Top