1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Some photos attachments become landscape instead of portrait

Discussion in 'Resolved Bug Reports' started by DJ XtAzY, Sep 27, 2013.

  1. DJ XtAzY

    DJ XtAzY Active Member

    It seems like some photos I took from my iPhone 5 in portrait mode are converted to landscape mode. Here's a pic of a haunted hospital in an amusement park, which was taken in portrait mode. I had no issues uploading the same image to other websites, such as FaceBook and phpBB, and they both display them correctly. I've attached a zip of the same photo for testing.
     

    Attached Files:

  2. Brogan

    Brogan XenForo Moderator Staff Member

    This is an iPhone issue and due to the exif information which specifies whether the image is landscape or portrait.
     
  3. AndyB

    AndyB Well-Known Member

    Digital Doctor likes this.
  4. AndyB

    AndyB Well-Known Member

  5. DJ XtAzY

    DJ XtAzY Active Member

  6. Digital Doctor

    Digital Doctor Well-Known Member

    They must do the rotations.
     
  7. Marcus

    Marcus Well-Known Member

    The photo does indeed store whether the image is landscape or portrait and my addon (http://xenforo.com/community/threads/half-of-mobile-images-displayed-wrong.60503/) as well as AndyB filehack rotate the image depending whether the image was stored in landscape or portrait mode.
     
  8. Marcus

    Marcus Well-Known Member

    The developers are aware of the issue.
     

Share This Page