1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Smiley Management Enhancements

Discussion in 'XenForo Development Discussions' started by HeadHodge, Sep 15, 2015.

  1. HeadHodge

    HeadHodge Member

    Hi,

    I'm using JQuery Mobile UI in one of my Styles. Overall it's working well, but I ran into a problem I can't figure out.

    I'm using tabs with my Smilies in the Wysiwig editor. Using JQuery Mobile UI appears to break the tab functionality and I'm trying to figure out what is causing the conflict. I noticed that the tabs div is using the classes 'tab' and 'tabs' and I suspect that may be causing my grief.

    If I remove those classes in the editor-smilies template, it sorta fixes the problem, because the smiliey tabs no longer appear.

    Anyone know if this is a redactor feature, a Jquery UI feature, or just a custom feature? I'm trying to buy a vowel here to head me in the right direction.

    Thanks in advance
     
  2. HeadHodge

    HeadHodge Member

    Thanks for moving my post (I guess). I still haven't received a reply to what should be a pretty simple question. :(
     
  3. HeadHodge

    HeadHodge Member

    Code:
    <xen:if is="{$showCategories}">
    <ul class="tabs Tabs" data-panes="#SmilieCategories > li">
    <xen:foreach loop="$smilieCategories" key="$smilieCategoryId" value="$smilieCategory">
        <li><a>{xen:if $smilieCategoryId, {$smilieCategory.title}, {xen:phrase smilies}}</a></li>
    </xen:foreach>
    </ul>
    </xen:if>
    
    Here's a code snippet from the editor_smiles template. I'm thinking either the class 'Tabs' or the attribute 'data-panes' is causing my problem.

    Can someone please tell me who is responsible for either of these two values (i.e. is it Xenforo.js, or JQuery, or Redactor, or something else) ? Someone coded this, so someone must know.
     

Share This Page