• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Server Errors

Brett Peters

Well-known member
#1
I dont know what is going on but ever since upgrading to 1.1b 3 I have been getting constant intermittent server errors, other domains on the same server are not effected. Bit confused really

Probably unrelated but I am unable to view forums because guests have posted threads bug (confirmed in bug reports)

Error 1
Fatal error: Exception thrown without a stack frame in Unknown on line 0

Error 2
Server Error

Mysqli statement execute error : Prepared statement needs to be re-prepared

Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
Zend_Db_Adapter_Abstract->fetchRow() in XenForo/Session.php at line 619
XenForo_Session->getSessionFromSource() in XenForo/Session.php at line 355
XenForo_Session->_setup() in XenForo/Session.php at line 339
XenForo_Session->start() in XenForo/Session.php at line 241
XenForo_Session::getPublicSession() in XenForo/Session.php at line 182
XenForo_Session::startPublicSession() in XenForo/Controller.php at line 286
XenForo_Controller->_setupSession() in XenForo/Controller.php at line 298
XenForo_Controller->preDispatch() in XenForo/FrontController.php at line 309
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
XenForo_FrontController->run() in /community/index.php at line 13

Any Ideas ?
 

Brett Peters

Well-known member
#4
About the only thing that I can think of is that I enabled file cache in the previous version of XF, Might remove that from config.php and keep an eye on it.

I also forgot to mention how impressed I am with the progress of 1.1 :oops:
 

Brett Peters

Well-known member
#6
Thanks for the link Jake but unfortunately that threads seems to be invisibly marked as solved but does not contain any information if any suggestions fixed the issue, MySQL is restarted daily so I can scratch that idea.

I have seen the same error posted on the net asking for help regarding the same error within XF but again no fix, only suggestions.

I could be completely wrong here but I would have thought that if It was a MySQL problem and the suggested fix was a MySQL restart that it would somehow affect other sites hosted on the same server which also use MySQL, I only get errors with XF.

[29 Nov 2010 13:58] Susanne Ebrecht
It is suggested that you try to increase the value of table_definition_cache in your MySQL configuration:
Unfortunately this is not an option for me and if this was found to be the confirmed fix I would probably be better off to downgrade XF to the last stable release that didnt give me errors.

I still have my fingers crossed that not enabling file cache in config.php will be the fix but only time will tell