1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Server error

Discussion in 'Troubleshooting and Problems' started by dtommy79, Apr 15, 2014.

  1. dtommy79

    dtommy79 Member

    Hi,

    My forum worked fine so far but when I try to access the front end I'm getting an unexpected error.

    I can access the admin area, I checked the server error logs and this error keeps coming up:

    Code:
    
    Error Info
    Zend_Controller_Response_Exception: Cannot send headers; headers already sent in /home2/*****/public_html/forum/index.php, line 16 - library/Zend/Controller/Response/Abstract.php:321
    Generated By: Unknown Account, 6 minutes ago
    Stack Trace
    #0 /home2/*****/public_html/forum/library/Zend/Controller/Response/Abstract.php(115): Zend_Controller_Response_Abstract->canSendHeaders(true)
    #1 /home2/*****/public_html/forum/library/XenForo/ViewRenderer/Abstract.php(63): Zend_Controller_Response_Abstract->setHeader('X-Frame-Options', 'SAMEORIGIN')
    #2 /home2/*****/public_html/forum/library/XenForo/ViewRenderer/HtmlPublic.php(18): XenForo_ViewRenderer_Abstract->__construct(Object(XenForo_Dependencies_Public), Object(Zend_Controller_Response_Http), Object(Zend_Controller_Request_Http))
    #3 /home2/*****/public_html/forum/library/XenForo/Dependencies/Public.php(212): XenForo_ViewRenderer_HtmlPublic->__construct(Object(XenForo_Dependencies_Public), Object(Zend_Controller_Response_Http), Object(Zend_Controller_Request_Http))
    #4 /home2/*****/public_html/forum/library/XenForo/FrontController.php(547): XenForo_Dependencies_Public->getViewRenderer(Object(Zend_Controller_Response_Http), 'html', Object(Zend_Controller_Request_Http))
    #5 /home2/*****/public_html/forum/library/XenForo/FrontController.php(141): XenForo_FrontController->_getViewRenderer('html')
    #6 /home2/*****/public_html/forum/index.php(25): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
    ["url"] => string(67) "http://www.******.com/forum/index.php?forums/main-forum.2/"
    ["_GET"] => array(1) {
    ["forums/main-forum_2/"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
    
    
    Any help is appreciated!
     
  2. dtommy79

    dtommy79 Member

    Anyway, I've run the File health check and it came up with an issue with the index.php file. I overwritten it from the install package and now it works.
     
  3. Tracy Perry

    Tracy Perry Well-Known Member

    Would have been interesting to do a diff compare to see what the changes were... that way you could see if there was an injection occurred.
     

Share This Page