• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Server error

#1
Getting this when I try to update...

Server Error
Mysqli prepare error: Unknown column 'display_order' in 'order clause'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in XenForo/Model/Smilie.php at line 87
  6. XenForo_Model_Smilie->getAllSmiliesForCache() in XenForo/Model/Smilie.php at line 113
  7. XenForo_Model_Smilie->rebuildSmilieCache() in XenForo/Deferred/ImportMasterData.php at line 40
  8. XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 66
  9. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 256
  10. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 390
  11. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 316
  12. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
  13. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
  14. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
  15. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  16. XenForo_FrontController->run() in /home/redligh1/public_html/forums/install/index.php at line 18
 

Jake Bunce

XenForo moderator
Staff member
#4
Thanks, looking into it, reverted back to 1.2.5 and uninstalled the plugin/ran the queries, going to try again now, though now i'm getting a 403 forbidden.
403 on what page?

A 403 is a server error. Your server is denying the request before it gets sent to XenForo. It may be necessary to contact your web host about this. But having more information (such as what page) might help to narrow it down.
 
#5
403 on what page?

A 403 is a server error. Your server is denying the request before it gets sent to XenForo. It may be necessary to contact your web host about this. But having more information (such as what page) might help to narrow it down.
Hey thank you for the help, I managed to get it to work by having my host revert to a backup (just the ftp, not the database). Then I deinstalled that smiley manager plugin and reinstalled the upgrade, works fine now.