• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Server error

tommydamic68

Well-known member
#1
Hello - hopefully someone can help with this issue, anty thoughts what is causing this server error? there are 7-8 pages of them.

Code:
Server Error Log
Error Info
Zend_Mail_Protocol_Exception: cannot connect to host; error = (errno = 0 ) - library/Zend/Mail/Protocol/Imap.php:100
Generated By: Unknown Account, Friday at 5:27 AM
Stack Trace
#0 /home/admin/public_html/community/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('ssl://sphynxlai...', 993, 'SSL')
#1 /home/admin/public_html/community/library/XenForo/Model/EmailBounce.php(304): Zend_Mail_Storage_Imap->__construct(Object(stdClass))
#2 /home/admin/public_html/community/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
#3 /home/admin/public_html/community/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 8, '')
#4 /home/admin/public_html/community/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 8, '', false)
#5 /home/admin/public_html/community/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
#6 /home/admin/public_html/community/deferred.php(23): XenForo_Model_Deferred->run(false)
#7 {main}
Request State
array(3) {
  ["url"] => string(45) "https://sphynxlair.com/community/deferred.php"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(3) {
    ["_xfRequestUri"] => string(53) "/community/threads/extremely-dirty-sphynx-cats.23712/"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}
Delete...Close
 

Kirby

Well-known member
#2
It's caused by the bounce management cron job trying to access the configured mailbox.

As far is I can see you've configured sphynxlair.com as the hostname, but the certificate (issued by PositiveSSL) seems to be for server.sphynxlair.com, so PHP would most likely not accept the certificate.

So either change the hostname or use the same certificate (issued by Let's Entrypt) you use for the webserver as that one is for sphynxlair.com
 

tommydamic68

Well-known member
#3
It's caused by the bounce management cron job trying to access the configured mailbox.

As far is I can see you've configured sphynxlair.com as the hostname, but the certificate (issued by PositiveSSL) seems to be for server.sphynxlair.com, so PHP would most likely not accept the certificate.

So either change the hostname or use the same certificate (issued by Let's Entrypt) you use for the webserver as that one is for sphynxlair.com
Thanks for the reply, is this something on my host side that could be fixed by them?
 

Kirby

Well-known member
#4
As said, you can either change the hostname (in XenForo Admin Home / Options / Email Options) - or the server operator can change the certificate (you might be able to do that yourself via some sort of server control panel, but that entirely depends on the hosting provider/server stup).
 

Fred.

Well-known member
#5
Try switching between TLS and SSL and change the port. Should be 465 or 587.
That solved my problem when it was not working.
Make sure you don't block these on your firewall.
 
Last edited: