1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Server Error Logs

Discussion in 'Troubleshooting and Problems' started by 51463, Apr 16, 2014.

  1. 51463

    51463 Well-Known Member

    Hello i have a problem with my forum. No one is able to reply to threads.They keep getting an error.
    I seen it said ******* in one of the errors so i thought id shut off this add-on. And people are able to post again. But i am still getting some errors when people create threads. So it's not totally working.

    I am getting tons of errors every minute
    The thing is it has been working well for the past 4 or 5 months. All of a sudden i am getting this problem and tons of error problems. So i don't think it is the add-on.



    R6JX2%RIIJ_M3M1{E0_FU1S.jpg
     
  2. MattW

    MattW Well-Known Member

    The MySQL errors could be related to the /tmp partition being full on the server.
     
  3. 51463

    51463 Well-Known Member

    I made a ticket to my hosting company asking them to make the /tmp partition bigger.

    I asked for 4 gigs. Is that too much? Or should i delete everything in the /tmp partition?

    I have no clue what i am talking about:(


    I also just noticed i cant even log into my Server Panel it says "
    500 - Internal Server Error"

     
    Last edited: Apr 16, 2014
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Does ElasticSearch use a lot of MyIASM for storage.. I noticed that most of those /tmp writes were MyIASM tables?
     
  5. 51463

    51463 Well-Known Member

    where could i check the MyIASM?
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    InnoDB should be the default n 5.5 and later of MySQL, but it can be disabled. I was more curious than anything since I'm contemplating getting ElasticSearch add-on for the enhanced search features - even though my site isn't large enough to need it that I'm going to use it on.
     
  7. 51463

    51463 Well-Known Member

    I had no choice but to get it. My forum got bigger and the default search was too slow. The elastic search is super fast.(althought i don't know the difference in features) I had someone install it.
    It was working perfect for the last 2 or 3 months.
    I'm waiting on my hosting company to get back to me. Im starting to think its a problem on their side. Not with any of my scripts or xenforo.
     
  8. MattW

    MattW Well-Known Member

    No, it doesn't write anything to the database, it uses it's own internal storage engine.
     
  9. 51463

    51463 Well-Known Member

    This is what my hosting company wrote back. So i think the problem is not with xenforo. It must be with another script. but the "Cool Script" I don't use and there is no user activity.

    The server log erros seemed to of stopped. Should i hire someone to do maintenace on my websites? Does anyone have any advice?

    Code:
    Hello,
    
    The issue is that you are over the 1,000,000 inode limit, and so your entire disk quota is exceeded. For future reference, /tmp is not a separate partition on VPS systems.
    
    The following directory has over 350,000 of those inodes;
    
    /var/www/vhosts/mywebsite.com/httpdocs/coolscript/$userfiles
    
    Also, almost 400,000 in;
    
    /var/lib/php/session
    
    I've cleared out the session folder for now. Make sure you look into your scripts and see which one is not properly closing out connections and such.
    
    Everything should be working properly at this time,
    
    Thank you
     
    Last edited: Apr 16, 2014
  10. Tracy Perry

    Tracy Perry Well-Known Member

    You ever have WordPress installed? I know you can use CoolScript with it for your fonts.
     
  11. 51463

    51463 Well-Known Member

    Actually i didn't mean the script "coolscripts" I just made that up after i deleted the real name of the script i use. I didn't know there was an actuall script called coolscripts.

    Well all the errors stopped. My severs hasnt been working good lately. And hostgator has been having problems all day and yesterday. So i'm not sure anymore weather the problem was caused due to hostgator or because of the sessions. But im guessing it was because of hostgator. Apparently a lot of their servers went down today. They even posted it on there website. So i will never know the problem unless it happens again in the future.
     

Share This Page