• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Select to quote no longer works

AndreaMarucci

Well-known member
#1
I've enabled Select-to-quote in ACP and I've tried on my Chrome and Firefox on OS X and it worked. Today a user told me that if he select just part of the message and click on Quote, all the message text is quoted and not only the selected part.

I've now tried at home using Firefox and Chrome (latest versions) and I've discovered that that user is right. Instead of quoting just the selected text, all the message text is quoted.

I've just upgraded from 1.3.5 to 1.4.3 and I've disabled the addon QuoteMe since it's redundant, just to tell the latest things I've done.

What's happening? How can I fix it?
 

AndreaMarucci

Well-known member
#4
Good qustion. Problem is that if I disable everything I really don't know which one is guilty. Maybe I can post here a list of my addons so that you can look at it and determine what addon could be. If I'm not wrong as soon as I've upgraded the select to quote worked so I've to understand which addon I've installed last...
 

ibnesayeed

Well-known member
#8
Another approach would be inspired by binary search in which you would divide the list of add-ons in two parts. Now enable first half and disable second half. If the issue disappears, the culprit is in the second half otherwise in the first half. Then divide the identified half further in tow halves and repeat the operation recursively. You should be able to pinpoint the culprit in about six tries if you have up to 64 add-ons and in seven tries if you have 128. :)