• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Search Problem

#1
Hey guys I am having a problem with the search function.

First of all let me explain my forum so you will understand what it is I am trying to accomplish.

Basically it is a forum where you give/take/trade items. The way I am setting it up is so that in every thread that has a item still available I put the following tag in the thread title (Find Items).
and once items have been taken I change the thread title to include (Item Taken)

The reason being so that a member can search Find Items in the search bar and it displays all available items to keep them from having to wonder through 14 different categories.

Now it seemed like a great idea but here is where I am having problems.

I just did the search "Find Items" and it returned 1 to 9 of 15 results on one page
when I click next I get this


Welcome to the LetsGiv Forum!

No results found.

:confused:

so puzzled I did a search for "letsgiv" knowing it should return a lot more results
the results were 1 to 20 of 49
I clicked next twice and had no problems

I difference that I noticed was that on the first search "Find Items" There was a next button down on the bottom right but not the bottom left where there was with the "letsgiv" search.

NOTICE: This would not be a big deal except I notice one of my items up for grabs is not in this list. I can only assume it is in the 10-15...

I am confused why it wouldn't display all 15 on the first page in the first place since it displayed 20 on the "letsgiv" search

I hope I explained this properly

Here is a screenshot to help out...

search.jpg
 

Jake Bunce

XenForo moderator
Staff member
#2
I was unable to reproduce this on my own forum. But I am guessing this has to do with the search results being cached. Try emptying the xf_search table between searches. Use this query:

Code:
TRUNCATE TABLE xf_search;