1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Restored forum and gallery has lost links to original images

Discussion in 'Troubleshooting and Problems' started by Temabu, Jul 17, 2016.

  1. Temabu

    Temabu New Member

    Hi, my forum was restored recently and now I can see the thumbnails in the xengallery but clicking on a thumbnail I see a broken link - e.g. the original image cannot be found.

    How can I restore the origina images? I presume they are in the attachments folder but how do I link them again?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If you did a complete backup and restore, it should all work as before.

    The error with the missing images would suggest either the backup or restore (or both) was incomplete.
     
  3. Temabu

    Temabu New Member

    I also get this: <p>An exception occurred: Cannot save file data/xengallery/dummy/dummy.jpg in /var/www/clients/client0/web17/web/library/XenGallery/Helper/Image.php on line 1022
    The backup was complete - all files and directories are intact. SQL was completely backed up. It may be to do with permissions on the folders? All members, forums, messages are intact.
     
  4. Temabu

    Temabu New Member

    error comes when trying top upload new media
     
  5. Temabu

    Temabu New Member

    to be correct. When I do a restore of the original folders an SQL I see the main page no problem. When clicking on anything form the home page the links are malformed. They do not include the index.php. So fo instance, the members link is http://peburi.ebario.com/members instead of http://peburi.ebario.com/index.php?members/ and the same for media (http://peburi.ebario.com/media instead of http://peburi.ebario.com/index.php?media/.
    What I then did was install 1.58 and gallery from scratch and replaced all the data in the database.

    I would rather restore everything back but then of course my links do not work.... Any ideas?
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You have Friendly URLs enabled.

    In order to use that, you must have a valid .htaccess file in place in the installation root and the relevant server configuration.
    If the .htaccess file is missing you can rename the htaccess.txt file to .htaccess which may resolve it.

    If it doesn't you will need to contact your host to have the server configured correctly.

    In the meantime, to restore functionality, you can disable Friendly URLs in the ACP.

    https://xenforo.com/help/friendly-urls/
     
  7. Temabu

    Temabu New Member

    I have nginx and followed the instructions on the link you sent. I had apache before so that was the difference. Thanks for the pointer. edited the .conf file, restarted nginx and voila!
     

Share This Page