1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 "Repair with keycache" on xf_search_index blocking DB restore process

Discussion in 'Installation, Upgrade, and Import Support' started by DeltaHF, Jun 8, 2014.

  1. DeltaHF

    DeltaHF Well-Known Member

    I have a large forum (9.4 million posts) and I'm moving the database to a new server. I backed up the database using mysqldump --opt, then began to restore the .sql file using a plain old mysql db_name < db.sql command.

    During the restore, the process seemed to hang (the size of the database in /var/lib/mysql wasn't increasing), and I ran
    SHOW PROCESSLIST in mysql to see what was going on. It showed a query in the state of "Repair with keycache", with the Info field of:

    /*!40000 ALTER TABLE `xf_search_index` ENABLE KEYS */

    What should I do next? I'm using ElasticSearch with XenForo, so perhaps there is some way I can avoid this? I found this old post from Kier which seems relevant, but I'm not sure.
  2. MattW

    MattW Well-Known Member

    DeltaHF and eva2000 like this.
  3. DeltaHF

    DeltaHF Well-Known Member

    Perfect! That's exactly what was needed. Thanks so much. (y)
    MattW likes this.
  4. MattW

    MattW Well-Known Member

    Glad it's sorted. Should be saving you quite a bit of database space as well with that table now empty.
    DeltaHF likes this.

Share This Page