Remove Search Tabs

Remove Search Tabs 1.3

No permission to download


Well-known member
AndyB submitted a new resource:

Remove Search Tabs - Removes search tabs from search page.


Removes search tabs from search page.

The search page is can be made far easier to use without the complication of tab options. If you used the Remove Profile Posts Plus add-on, this companion add-on will simplify the search page.

Modifies the code in the following templates:
  • seach_bar
  • search_form_tabs
  • This add-on works with XenForo v1.2x and above
  • Only works with default templates

Read more about this resource...


Active member
@AndyB hi :) Thank you for your cool addon.
I got some issue with it + xenmediagallery addon from Chris Deeming.
By default XF quick-search (below nickname) searches for all content (so first search tab by default like
So using your addon it also search all content and pictures too. But i got it 212.000+ pictures after big migration from phpBB... So using search in all content = it finds mostly pictures but not text content as users expected :(

The question is how to set main-input search option after installing your addon to search only in threads and posts? Like ? :) Hope you understand me :D


Well-known member
On my forums some newbies ask: "how do I search on this site?" and I provide them the following link:

Your add-on is almost perfect but when manually accessing to /search/ it's still loading the "Search Everything" tab by default. Any chance that you change that behavior? If you're able to do so then there is no need to change links from "search" to "search/?type=post".


Well-known member
Btw the quick search (the one located at the top right corner of every page) searches in threads (and posts, obviously) and profile posts. I think you should also prevent that quick search from searching on profile posts...


Well-known member
Does this really work with 1.5.14? On a blank test installation just with current Media Gallery and bdAPI additionally installed, the search tabs are still visible in default theme.

What am I doing wrong, please?