Fixed register_connected_account doesn't seem to correctly apply the _xfRedirect field

Jake B.

Well-known member
Affected version
2.2.8
When logging in with Google/Twitter/another OAuth provider for the first time you are prompted to choose a username. After this, you get redirected back to the register confirm page rather than the page you were on previously even though $redirect is being passed into the template with the correct URL. It doesn't seem to be getting passed into the <xf:redirect /> tag, so it just defaults to the index page
 
Last edited:

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.9).

Change log:
When registering with a connected provider, correctly redirect to the specified return URL
There may be a delay before changes are rolled out to the XenForo Community.
 

briansol

Well-known member
I realize this is set for 2.2.9, but this has become a massive issue. people cannot login.
for over a month.

we need a hotfix for this.
 

Lukas W.

Well-known member
That's an issue on your end you've configured the wrong redirect url in your Google developer console when setting up your oauth app.
 

briansol

Well-known member
Thanks, somehow my client ID info was deleted in google tools.
made a new id and put in the new keys and it's working.

very strange.
 
Top