1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Received: from localhost (unknown [172.xx.xx.xx])

Discussion in 'Troubleshooting and Problems' started by jason enzer, May 6, 2016.

  1. jason enzer

    jason enzer New Member

    Im trying to use SMTP setup in XF1.5. problem is i cant find the location where XF is pulling localhost as the machine name. all the usual suspects are passing correct machine name. is there a config file somewhere that you guys might know of that is passing zend localhost? ( not hosts, network, etc )


  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. jason enzer

    jason enzer New Member


    I did locate the setting. and it did bring my spam score down from 5.3 to 0.1 but ultimately it was reverse DNS that was causing the gmail spam issues.

    for anyone else using smtp to send, wanting to prevent higher scoring from causing spam detection. there are 2 fields

    name and host are located in the below file

    /library/Zend/Mail/Protocol/Smtp.php Line 81: protected $_name = 'localhost'; change to whatever your hostname of xenforo bb is
    /library/Zend/Mail/Protocol/Smtp.php Line 118: public function __construct($host = '', Array $config = array()) change to ip of your xenforo instance

    some smtp servers will not allow you to be above 5.5-6 so that leaves one keyword that kicks up score 1 point and your email is DOA.

Share This Page