1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Rebuilding Error

Discussion in 'Troubleshooting and Problems' started by Yoshi910, Feb 28, 2013.

  1. Yoshi910

    Yoshi910 Member

    Whenever I try to rebuild from /install, it runs fine for about 5 minutes. When it starts rebuilding the templates, it suddenly stops and shows the following message:

    "The requested page could not be found."

    I have tried rebuilding over 10 times, and they have all failed. I also checked server error logs, it has no errors relating to this problem.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    1) Remove any excess styles or languages that you aren't using. That will speed up the rebuild.

    2) You can try adding this line to your library/config.php file to increase the timeout (default is 10):

    $config['rebuildMaxExecution'] = 10;
  3. Yoshi910

    Yoshi910 Member

    I have removed a couple of styles which I almost never used. I also changed the value for that config option to 20. Then I ran the rebuild process again. Sadly, same thing still happens.

    While it's rebuilding the templates, it randomly stops and shows the following message:

    An error occurred or the request was stopped.
    After that, it shows the following error:

    The requested page could not be found.
    I use memcached and APC caching, if that helps.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Well the "not found" error may indicate a server issue. It sounds like the server is interfering with the request if it says the resource was not found. It could be due to a misconfigured Apache module like mod_security. You would have to ask your host about this. Ideally there will be logs on the server that will reveal the nature of the problem and point to the cause. Or more generally I would ask your host to disable mod_security and any other restrictive Apache modules to see if that fixes it.
  5. Yoshi910

    Yoshi910 Member

    It's actually a VPS, so I can disable it my self. I will go ahead and try that right now. Also, where would I check for the logs?
  6. Yoshi910

    Yoshi910 Member

    Before I continued to disable mod_security, I looked at the logs once more.

    [Fri Mar 01 04:35:53 2013] [warn] [client] mod_fcgid: read data timeout in 40 seconds, referer: http://domain.com/admin.php?tools/cache-rebuild
    [Fri Mar 01 04:35:53 2013] [error] [client] Premature end of script headers: admin.php, referer: http://domain.com/admin.php?tools/cache-rebuild
    [Fri Mar 01 04:36:01 2013] [warn] mod_fcgid: process 25956 graceful kill fail, sending SIGKILL
    Edit: I have fixed this issue by switching my PHP handler from mod_fcgid to cgi.
    Adam Howard and Kira666 like this.

Share This Page