1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Really poor performance compared to VB...

Discussion in 'Server Configuration and Hosting' started by RobParker, Apr 9, 2012.

  1. RobParker

    RobParker Well-Known Member

    I'm sure a lot of this is just getting the config set correctly but we're seeing really poor performance compared to what we managed with VB, particularly the number of users we handle online at a time.

    With VB we could handle several thousand users online at once but after going live with XF a few days ago, when we get over 500 or so users we get errors that we've exceeded the max_user_onnections limit.

    Is there anything obvious we should be looking to change in our config settings?
     
  2. RobParker

    RobParker Well-Known Member

    An exception occurred: User xxxxxx already has more than 'max_user_connections' active connections in /var/hsphere/local/home/www/domain.co.uk/library/Zend/Db/Adapter/Mysqli.php on line 333
     
  3. Digital Doctor

    Digital Doctor Well-Known Member

    Any tips in here ?
     
  4. RobParker

    RobParker Well-Known Member

    I had a search before posting and couldn't find anything useful.

    Our site is currently busy but it's no where near the level which vb used to be able to handle fine.
     
  5. Digital Doctor

    Digital Doctor Well-Known Member

  6. RobParker

    RobParker Well-Known Member

    We have our values set high already so not really. It looks like something is causing XF to need many more connection to the database than VB did and I wondered if anyone knew if this was the case?
     
  7. Sadik B

    Sadik B Well-Known Member

    That error means that you are hitting the mysql connection requests upper limit set in your my.cnf mysql configuration file. You probably need some server tweaking. General outline is, a> Get rid of all unwanted Apache modules to reduce apache memory footprint b> Run php as fastcgi or fcgid if possible instead of mod_php c> Make sure everything that can be cached is cached d> Make sure mysql caching is turned on and mysql config variables are tweaked for your requirements and e> Ensure you use all of xenforo's performance enhancing features.
     
  8. Sadik B

    Sadik B Well-Known Member

    You can turn on debug and see the explain to see what all queries are running and identify what could need so many connections.
     
  9. RobParker

    RobParker Well-Known Member

    Cheers

    We're on a managed server so I asked them to see if they can go through some mysql tuning (from what I can tell we don't have any innodb entries in our my.cnf file) and will see how that goes.
     
  10. Walter

    Walter Well-Known Member

    The forums I transferred from vBulletin to Xenforo all run faster than with vb.

    The connection error probably is a consequence of a wrongly configured Mysql ini - if you have many queries running for a longer time than they should they will eat up your connections. Get someone with Mysql knowledge fast.

    If you have no Innodb entries: this alone is a big error. You are creating a massive bottleneck!
     
  11. RobParker

    RobParker Well-Known Member

    Cheers Walter, my hosts are getting their MySQL guy who optimised us for VB to take a look tonight. He knows his stuff but probably isn't familiar with XF, are there any specific things that you think it'd be useful me to mention to him?
     
  12. Walter

    Walter Well-Known Member

    If he knows Mysql and Innodb there isn't much specific about Xenforo.

    Simply enabling Innob-Caching by adding a few lines to the mysql config file will already do wonders :)
     
  13. MGSteve

    MGSteve Well-Known Member

    I had a similar issue when importing the VB data into XF, but that may be a CLI importer specific issue. However, the symptom was the amount of connections used by mySQL.

    In the end, I had to turn down the wait_timeout so the connections were closed quicker and increased the max_connections.
     
  14. Digital Doctor

    Digital Doctor Well-Known Member

    This should be documented somewhere for benefit of future users.
     
  15. MGSteve

    MGSteve Well-Known Member

    Well, there's a bug in the CLI system that Mike's aware of causing multiple connections to be created - which initially resulted in a max-ed out server and missing threads & posts, but I agree, it could do with being noted - if its not already noted in the CLI thread I started and that most people find if they do a search on it ;)
     
  16. Digital Doctor

    Digital Doctor Well-Known Member

    Where is the bug report ?
     
  17. MGSteve

    MGSteve Well-Known Member

    erm, I didn't file one - Mike said he was aware of the problem when I posted about it, I didn't think I needed to post a bug report?
     
  18. Digital Doctor

    Digital Doctor Well-Known Member

    erm, I think it would be helpful for tracking the bug and informing others about it.
     
  19. RobParker

    RobParker Well-Known Member

    Would you mind posting exactly what so I can compare?

    Cheers :)
     
  20. Walter

    Walter Well-Known Member

    Largely depends on your configuration but take a look at e.g. innodb_buffer_pool_size
     
    RobParker likes this.

Share This Page