1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Readactor 1.0.1

Stylish design replacement for Redactor

  1. CyberAP

    CyberAP Well-Known Member

    CyberAP submitted a new resource:

    Readactor - Stylish design replacement for Redactor

    Read more about this resource...
     
  2. Matthew Hawley

    Matthew Hawley Well-Known Member

    Very nice indeed! Great work! (y)
     
  3. RoldanLT

    RoldanLT Well-Known Member

    Hope to see this built-in on charm style (y)
     
  4. CyberAP

    CyberAP Well-Known Member

    I've copied it from Charm, so yes, it's in the future update :)
     
    RoldanLT likes this.
  5. Matthew Hawley

    Matthew Hawley Well-Known Member

    I don't think he will, because normally style developers dont release part of their code for paid styles...Though he'll probably make another design. :)

    EDIT: nvm, just saw CyberAP's post lol.
     
  6. Arkshine

    Arkshine Active Member

    Well, it's weird, add-on is installed, I can see the options in styling properties and is well enabled ; but for some reason, nothing is changed when I look at the editor.

    Tried to install 2 times. Any ideas ?

    EDIT: Also, I see no modifications in TM.
    EDIT2 : Ah, I remember the XML format has changed or something at some point.
     
    Last edited: Jul 8, 2013
  7. MattW

    MattW Well-Known Member

    To work with 1.2 Beta 4, the XML needs updating for the Template Modification.

    Code:
      <public_template_modifications>
        <modification template="editor_ui.css" modification_key="readactor_css" description="" execution_order="10" enabled="1" action="str_replace">
          <find><![CDATA[.redactor_dropareabox.drop {
        background: #f4f4ee;
        border-color: #e0e5d6;
    }]]></find>
          <replace><![CDATA[.redactor_dropareabox.drop {
        background: #f4f4ee;
        border-color: #e0e5d6;
    }
    
    <xen:include template="readactor.css" />]]></replace>
        </modification>
        <modification template="editor_contents.css" modification_key="readactor_editor_contents.css" description="" execution_order="11" enabled="1" action="str_replace">
          <find><![CDATA[}
    body
    {]]></find>
          <replace><![CDATA[<xen:include template="readactor_editor_contents.css" />
    }
    body
    {]]></replace>
        </modification>
      </public_template_modifications>
     
    Arkshine, Shelley and CyberAP like this.
  8. Arkshine

    Arkshine Active Member

    Yeah, seen that after, but tried myself before and it was not working, so I've added manually. Thanks anyway.
     
  9. CyberAP

    CyberAP Well-Known Member

    resonansER, RoldanLT and MattW like this.
  10. CyberAP

    CyberAP Well-Known Member

    Sorry for the delay guys. Should work fine on latest beta and RC.
     
    shenmuee and RoldanLT like this.
  11. Alexey.P

    Alexey.P Member

    Wow finally!
    This one finally make sense on my 1.2 beta5..

    Only 1 thing tho, any idea why every time I write/enter/anything in the form I see a scroll at the bottom? like I scroll that usually have for a long long line
     
  12. CyberAP

    CyberAP Well-Known Member

    That doesn't happen on my install. Using RC1 though.
     
  13. MattW

    MattW Well-Known Member

    I don't have that either (didn't have it on Beta 5 or on RC1)
     
  14. Alexey.P

    Alexey.P Member

    I forgot to mention that I am using RTL (Right To Left) maybe this is why?
     
  15. Alexey.P

    Alexey.P Member

    This is how it looks like, not to mention that in order to mark the text, I have to click (mouse click) 3 times instead of 2. if I click 2 times, it just behaving like nothing happen and give up that scroll anyway o_O
    issue.PNG
     
  16. CyberAP

    CyberAP Well-Known Member

    And when you disable Readactor the scrollbar disappears?
     
  17. Alexey.P

    Alexey.P Member

    In fact I think there is some thing to do with the RTL (Right To Left), I switched to English and Readactor works perfectly, no scrolls or 3-time click to get it marked.

    You think you can launch a small fix for the RTL users? :) that's quite a lot of languages.
     

Share This Page