1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ragtek's Global RSS/XML Feed - Not working?

Discussion in 'Troubleshooting and Problems' started by maxwolfie, Jul 25, 2012.

  1. maxwolfie

    maxwolfie Active Member

    Hi All,

    I have just installed this, but cannot get it working. I believe the addon is supposed to spit out an RSS feed to <xenforo root>/feeds/, but this isn't happening. Do I need to manually create the /feeds/ directory? The instructions did not tell me to. How do I specify what forums are used to generate the feed, again the instructions are very limited.

    I'm also getting an error within the ragtek framework mod (prerequisite for some ragtek mods), when I click on "Show all ragtek addons" in AdminCP -> Tools, I get this:

    Server Error
    Invalid argument supplied for foreach()
        XenForo_Application::handlePhpError() in Ragtek/FW/Model/F.php at line 41
        Ragtek_FW_Model_F->_getNewestAddonVersion() in Ragtek/FW/Model/F.php at line 72
        Ragtek_FW_Model_F->getNewVersions() in Ragtek/FW/ControllerAdmin/Manage.php at line 31
        Ragtek_FW_ControllerAdmin_Manage->actionGetRagtekAddons() in XenForo/FrontController.php at line 310
        XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
        XenForo_FrontController->run() in /home/hackslas/public_html/admin.php at line 13

  2. SchmitzIT

    SchmitzIT Well-Known Member

    It should show a feed at forum-url/feeds/global.rss. I.e. http://www.entropiaplanets.com/forums/feeds/global.rss (the /forums/ is part of the installation path of the forum).

    You do not need to create a folder or specify any forums, as the feed will show you the feed for all forums you are allowed to see (IIRC).

    And I receive the same error when checking the framework thingy. I do recall reading somewhere that Ragtek is looking into replacing the framework for this add-on, but cannot recall where I saw it.

    HTH :)
  3. ragtek

    ragtek Guest


    people didn't like the framework idea, so i had to remove it...

    the global thread feed isn't located at <xenforo root>/feeds/ it's like schmitz said => feeds/global.rss
  4. maxwolfie

    maxwolfie Active Member

    Thanks guys, still a bit confused though as I don't have a feeds directory? At what point is it automatically created? And how do I specify what forums to generate the global feed from?
  5. ragtek

    ragtek Guest

  6. maxwolfie

    maxwolfie Active Member

  7. ragtek

    ragtek Guest

    That's not possible:(
  8. maxwolfie

    maxwolfie Active Member

  9. ARSamo

    ARSamo Member

  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I don't understand. Are you having a problem with ragtek's global feed addon?
  11. ARSamo

    ARSamo Member

    trying to syndicate mysite new created feeds in wordpress via Feedwordpress plugin but got this error:
    Diagnostic information
    HTTP request failure
    Operation timed out after 20000 milliseconds with 0 bytes received
    HTTP Transport:
    string(12) "WP_HTTP_curl"
    And while trying to add in facebook fanpage via with RSS Grafitti Application got this error:
    Error: We are unable to process this feed URL.
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It appears that your reader is unable to make the HTTP connection to the feed. I am unable to access that feed with my browser:


    It just keeps loading and nothing happens. That explains the error message.

    So the problem is that the feed isn't working. Ragtek's global feed was made for XenForo 1.0. It's possible it doesn't work in 1.1. But 1.1 has its own global feed now so I suggest you try using that.
  13. ARSamo

    ARSamo Member

    Thanx jack......... but the problem is before xf, on vb feeds (http://domain.com/forum/external.ph...,38,39,45,49,52,53,57,59,64,69,72,75,86,90,96) were published with picture and preview of thread's 1st post and now feeds are published with only title of thread.... see the difference on picture below ...


    how can i fix this....... Thanx
  14. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Ok. XenForo's default global feed does not include excerpts from the thread. That is normal. Ragtek's old global feed addon includes excerpts but that addon is apparently not working for you. I don't have a solution for you other than ragtek's addon.
  15. ARSamo

    ARSamo Member

    After checking the logs from regtek Framework... found this....

    Server Error
    Invalid argument supplied 
    for foreach()
    XenForo_Application::handlePhpError() in Ragtek/FW/Model/F.php at line 41
    ->_getNewestAddonVersion() in Ragtek/FW/Model/F.php at line 72
    ->getNewVersions() in Ragtek/FW/ControllerAdmin/Manage.php at line 31
    ->actionGetRagtekAddons() in XenForo/FrontController.php at line 310
    ->dispatch() in XenForo/FrontController.php at line 132
    ->run() in /home/content/52/7902852/html/admin.php at line 13
    and checking in safari browser ... feed url (feed://www.sindhsalamat.com/feeds/global.rss) works after some loading...
  16. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's the same error as in the first post. Ideally you should contact ragtek about this. He isn't on this forum anymore, but he is on github:


Share This Page