1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Quoting a Post - Quick Reply Button greyed out

Discussion in 'Troubleshooting and Problems' started by MrC, May 30, 2012.

  1. MrC

    MrC Active Member


    This is what was happening on my forum:

    1. If I replied to a thread without quoting anyone, it would be fine.

    2. If I quoted someone, typed in my reply, then hit the Post Reply button, the Post Reply Button would be greyed out for about a few seconds, then it would turn back on again. It would look like my reply was not submitted. But if I refreshed the page, I would see my new reply.

    This is causing many duplicate posts on my site. Many members are dodging the problem now by hitting F5 everytime they reply to a quote. But some people thought their replies were not submitted and hit the Post Reply button again and again -> duplicate posts.

    Thanks :D.
  2. Adam Howard

    Adam Howard Well-Known Member

    A few things...

    Do you have any modifications / add-ons installed and have you tried disabling them?
    Does this apply to every skin you have or just some?
    Have you made any template edits and if so, have you tried without them?
    What browser are you using?
  3. MrC

    MrC Active Member

    1. I tried disabling all addons
    2. Talking about skin, I just found this problem, which happened to all skins. I clicked Style Properties-> Default Style -> General. Up to that point it was fine, then when I chose Body, it brought me back to Style Properties's main display.

    So something must have gone wrong there, may be database corrupted?
  4. Adam Howard

    Adam Howard Well-Known Member

    Did you recently import from another forum software? If not, it is unlikely. InnDB (which XenForo uses) is very stable.

    A few things come to mind....

    What do you have in your .htaccess file?
    Have you tried to disable add-ons via the config file?
    If not add this
    $config['enableListeners'] = false;
    This will further rule out any possible conflict.....

    Again, did you add any template errors?

    Have you checked your error logs?
    MrC likes this.
  5. MrC

    MrC Active Member

    There were no errors in the logs.

    I ve just created a default style, disabled all addons, put that line in the config. The problem with skins as mentioned disappeared!

    I need to test a bit more to see if the double posting problem is still there. Also need to check which addons caused the problem. Will report back...

    Edit: Couldn't disable Template Modification System...
  6. Adam Howard

    Adam Howard Well-Known Member

    TMS plugs into the core, but I can confirm (as with A LOT of people here) that is is stable. So don't worry about TMS.

    You can however disable each template edit in it (one by one) if you suspect a conflict with a modification.

    But as you did add that into your config file.... We now know something is conflicting (rare in XenForo).... Now all you need to do is track it down.

    Glad I was able to help :)
    MrC likes this.
  7. MrC

    MrC Active Member

    The addon that caused #3 was Template Syntax 1.6. It could be that I made some mistakes when trying to install the addon. I am disabling the addon for now and will observe if double posting still occurs.
    TheVisitors likes this.
  8. MrC

    MrC Active Member

    Update: The problem has gone. I updated Template Syntax a few days ago. I also did a lot of changes to the forums in the day so I wasn't sure what was the culprit. I thought it was an issue with the server.

Share This Page