1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Question

Discussion in 'XenForo Questions and Support' started by Jacob Stretton, Oct 16, 2014.

  1. Jacob Stretton

    Jacob Stretton New Member

    How to make your xenforo website your actual website
    Is there a way to make it so instead of ipaddress/xenforo/.com it can be ipaddress.com
     
  2. BoostN

    BoostN Active Member

    Place the software in the root directory on the web server. Like /public_html/ <put xenforo here>.

    So that will have domain.com/ show the xenforo homepage.
     
  3. Jacob Stretton

    Jacob Stretton New Member

    Thanks, I did it.
    But now when I type the ip in, it takes me to the right website but not the right page
    Minespud - Error
    The requested page could not be found.




    How do I make it send to the index page?
     
  4. BoostN

    BoostN Active Member

    Have you installed the software on this server before in a different directory? Such as in /forum/ or in /xenforo/

    If so, you'll need to edit the forum URL in the admin control panel.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    The Board URL in the ACP has no effect on where the software is installed, it is primarily related to links in emails, sitemap, etc.

    What is the actual link to your site?
     
  6. Jacob Stretton

    Jacob Stretton New Member

    minespud.com
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Does it work if you disable add-ons, specifically the portal and set the index page route back to forums/ ?
     
  8. Jacob Stretton

    Jacob Stretton New Member

    I just pasted
    $config['enableListeners'] = false;
    in the config, saved it
    and then I typed in minespud.com and the same thing happens
     
  9. Jacob Stretton

    Jacob Stretton New Member

    ooh i will set the index route at forums now
    Ok just set the index as forums/ and it doesnt say the error anymore
    edit, just enabled plugind, and i figured out it was a problem with the index page route, when I have it set as index.php?portal/
    it gives an error
    How to fix?
     
  10. Brogan

    Brogan XenForo Moderator Staff Member

    You will need to seek support in the add-on thread.
     
  11. Jacob Stretton

    Jacob Stretton New Member

    I fixed it it was supposed to be
    portal/
    instead of
    index.php?portal/
     

Share This Page