1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 problems accessing another db after upgrading to 1.4.4 xmapp

Discussion in 'Troubleshooting and Problems' started by Ian S, Jan 19, 2015.

  1. Ian S

    Ian S Active Member

    of so for quicknest i have 3 dbs in my xmapp which i use 1 at a time to check differences, anyway i downloaded upgrade and put the files in xmapp, all updated great and worked fine, but as soon as i called 1 of the other 2 db's, i get a message upgrade in progress only access in debug, is there a file that i can edit change to get rid of this as all 3 dbs worked before the upgrade

    thanx in advance
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Ian S

    Ian S Active Member

    no brogan you missed my drift i have 3 different db's, i then change the config in library to point it to the correct db, this has worked fine until today when i upgraded one now it comes up with the message on the others, do i need to update them all now then as files in community are different and the db copy knows
  4. Tracy Perry

    Tracy Perry Well-Known Member

    If you have 3 separate DB's, then ALL 3 have to have the update process ran on them... and yes, I believe that there is a LOCK file that is created when an update is ran.
    I'll log into SSH on one of my forums and see if I can find it.


    It may be the install_lock.php under the /internal_data directory. Try renaming that and see if the upgrade will work. Notice I said RENAME it - not delete it.
  5. Ian S

    Ian S Active Member

    thanx tracy im in the process of updating all 3 now ill then save the dbs all done and this should sort it, xf must recognise theres new files in the xf directory

Share This Page