• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Problem with Slavik's Mobile App since certificates expired

RobParker

Well-known member
#1
I'm not sure if anyone can help but @Slavik isn't responding to PMs and since the app was abandoned there doesn't seem to be any support. The addon thread I posted in about this last week also seems to have been deleted (or at least I can't seem to find it by searching my posts/alerts).

We still have XenApp installed but it's been abandoned for a while now. After our certificates expired we started getting these errors (and they were crashing our site, causing 504 errors):

Code:
19-Oct-2017 21:31:58 UTC] PHP Fatal error:  Maximum execution time of 120 seconds exceeded in /home/sites/xxxxxx/public_html/xenapp/lib/push.php on line 274
I disabled the XenApp addon on 20th October but we've still been having issues and get this error:

Code:
[23-Oct-2017 07:32:24 UTC] PHP Catchable fatal error:  Argument 1 passed to XenForo_Model_Thread::markThreadRead() must be of the type array, boolean given, called in /home/sites/xxxxxxx/public_html/xenapp/lib/api2.php on line 5490 and defined in /home/sites/xxxxxx/public_html/library/XenForo/Model/Thread.php on line 2142
I'm not sure if anyone's experiencing the same but I assume some people possibly are as quite a few forums had it installed.

I didn't want to fully uninstall the addon without being sure that'd fix things and not make them worse. Anyone have any ideas/suggestions?

(I wasn't sure where to post this but given the situation I'm hoping it's allowed somewhere on here).
 

RobParker

Well-known member
#3
uninastall it, much better then try to fix it!
I don't want to "fix it", I just want to make sure the addon doesn't do any more damage. I'm wary of uninstalling it in case something needs doing prior to uninstalling it to stop the problem occurring. It's disabled so I don't know why we're still getting errors related to it but I'm not 100% sure they won't continue even if uninstalling it.
 

ŽivaAkcija

Well-known member
#4
That why i run test forum, with all plugins in live ones, first try everything in test ones and implemented on live ones, no mistake.
 

RobParker

Well-known member
#5
That why i run test forum, with all plugins in live ones, first try everything in test ones and implemented on live ones, no mistake.
I don't think you understand. The addon has been running for months (and working great) but was recently abandoned. It requires certificates to run which have now expired and won't be reissued, hence causing this issue.
 

RobParker

Well-known member
#10
Again, I don't think you're being helpful. I don't want to "just uninstall it" without properly understanding the consequences given it's on our live site and there's no longer any support. If it's still having an impact while disabled, it seems likely that it'll still have an impact when uninstalled.

I'm trying to get some answers as to whether that's the case. For example, will the app keep hitting our site, fail to find the API files if I delete them and cause more server issues? i.e. Has abandoning the app with no support just turned it into a DDOS tool