1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Problem With My Test Forum

Discussion in 'XenForo Questions and Support' started by TheSalt, Aug 13, 2014.

  1. TheSalt

    TheSalt Active Member

    Hello Gang!

    I wanted to do the latest upgrade but in an attempt to be a better admin I decided to tackle making a test forum first. Below are the steps I took.
    1. Backup directory and database
    2. Within the root folder I created a new folder "testforum"
    3. Created a new database "testforum"
    4. Uploaded the backup database to the new database "testforum"
    5. uploaded the back directory files to the root folder "testforum"
    6. updated the .config file to use the "testforum" database
    When I loaded www.myforum.com/testforum/ I couldn't sign in. The theme still was rendering but I get a page error "The requested page could not be found." so I tried www.myforum.com/testforum/admin.php and that allowed me to sign into the ACP. I changed the ULR in "Basic Board Information" and saved. It still doesn't allow me to sign in as a member. The theme/skin, members, and content seem to be there but I did notice the xenportal slider images are not rendering. Did I miss a step? Hopefully someone here knows where I went wrong.

    Many Thanks:)
    Nick
     
  2. TheSalt

    TheSalt Active Member

    AH! I stand corrected! the threads show up in the forum list but when I click on them I get the same error as when I sign in. "The requested page could not be found."
     
  3. Martok

    Martok Well-Known Member

  4. Brogan

    Brogan XenForo Moderator Staff Member

    It sounds like a Friendly URL issue.

    Do the pages work if you disable it in the options?
     
    TheSalt likes this.
  5. TheSalt

    TheSalt Active Member

    I noticed I do didnt something. I didnt create a new user and password for the DB so I fixed that, thank you.

    I unchecked it and everything worked perfectly. It appears that was the problem. Thank you Brogan, again.:D

    Something I want to make note of though... I checked the DB sizes against each other and the main forum DB is 73.03 MB and the new one is 62.24 MB. Before seeing your fix I noticed the DB differences and tried to backup and import again. It still showed as 62.24 MB and was doing the same thing. I then turned off the Friendly URL and everything works perfect. Everything seems to be working right on the test forum along with members and content.

    I have noticed in the past that is takes some time for the DB size to update on the cpanel. I'm still guilty of using myphpadmin for backups as shell is out of my understanding still. It is on my to learn list. This is also why I worry about the effectiveness of my DB backups.

    Thanks again! You all are always so kind and helpful. :love:

    Be well,
    Nick
     
  6. TheSalt

    TheSalt Active Member

    Oh! Also I'm not sure about the "cache". How do I know if I'm using it on my live site? Not sure if I need to address this or not.
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Using SSH is fairly straightforward.

    I posted some instructions here: http://xenforo.com/community/threads/how-can-i-copy-a-db-dump-to-my-localhost.73038/#post-757333

    Essentially the commands are:

    Dump:
    Code:
    mysqldump -u<user> -p --single-transaction --skip-lock-tables db_name > /path/to/backup/db_name_$(date +%d.%m.%y).sql
    
    You will be prompted to enter the password.


    Zip (optional):
    Code:
    tar -czf db_name_$(date +%d.%m.%y).tar.gz /path/to/backup/db_name_$(date +%d.%m.%y).sql
    

    Restore:
    Code:
    mysql -u<user> -p db_name <db_name.sql
    You will be prompted to enter the password.
     
  8. Brogan

    Brogan XenForo Moderator Staff Member

    If you have a cache configured, it will be defined in config.php.
     
    TheSalt likes this.
  9. TheSalt

    TheSalt Active Member

    UGH! I'm really trying... I keep getting "mysqldump: Got error: 1045: Access denied for user******* (using password: YES) when trying to connect" after I type in my DB password
     
  10. TheSalt

    TheSalt Active Member

    Also I was using the terminal in OSX. I'm pretty bad at this...

    Code:
    mysqldump -u**** -p **** >> ****backup.sql
     
  11. TheSalt

    TheSalt Active Member

    Got it worked out! This is awesome! I had to add my IP to the cpanel to allow me to access it via SSH. Thanks so much for the help. I'm working on importing back into the DB using SSH now.
     

Share This Page