• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Problem with Internal_Data

Enguerran A

Well-known member
#1
Hi, i'm customizing a lot's of thing and I have some problem with the Internal_Data folder. For example, I created a block for Xenporta and I deleted it (block was broken). I re-made it and re-sent but Xenforo told me that there was a problem with my block (I solved it). I check on the folder and I saw that it was the former version.

My question is, what is the utility of this folder and can I delete it without risks or not because right now, it's very hard to make things working :/ (and this folder is very very very heavy)
 

Rigel Kentaurus

Well-known member
#2
Hi, i'm customizing a lot's of thing and I have some problem with the Internal_Data folder. For example, I created a block for Xenporta and I deleted it (block was broken). I re-made it and re-sent but Xenforo told me that there was a problem with my block (I solved it). I check on the folder and I saw that it was the former version.

My question is, what is the utility of this folder and can I delete it without risks or not because right now, it's very hard to make things working :/ (and this folder is very very very heavy)
internal_data stores important things like, attachments, you would loose all of them should you delete it
 

Enguerran A

Well-known member
#3
And what about the Templates folder? Can I delete it and rebuild with a custom options? It would help me a lot since there apparently is different version of a same template.
 

Rigel Kentaurus

Well-known member
#4
And what about the Templates folder? Can I delete it and rebuild with a custom options? It would help me a lot since there apparently is different version of a same template.
You shouldn't need to, Xenforo takes care of reparsing the templates

Safest thing is to switch in the ACP on performance to not store templates as files. If that does not remove the folder, yeah, you can delete it
 

Enguerran A

Well-known member
#6
Ohhh :/ I'm feeling unlucky right now xD I have deleted all my forum in order to do a clean install ^^
But thanks anyway, at least I'll know that to the future :)