1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Problem with address

Discussion in 'Troubleshooting and Problems' started by Jayt, Oct 29, 2014.

  1. Jayt

    Jayt Member

    I'm not sure the best title for this. But once I'm logged in I cannot access my site the same way anymore. For example if the address is www. site.com/forum/ once logged in it now has to be www.site.com/forum/index.php?forums I think this just started happening after installing arrow chat but I'm not sure. This makes it so the link in the admin cp doesn't work because www.site.com/forum/index.php is invalid too. Any idea what would cause this or how to fix it?
    Last edited: Oct 29, 2014
  2. Jayt

    Jayt Member

    Also if I log off then back in I get an error too since it tries to open www.site.com/forum/index.php which gives an error that the page doesn't exist. I do get logged in but I have to click on the forums link to see the forums.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Without a link it's difficult to say what the problem is.

    However, it sounds like you have Friendly URLs enabled and the .htaccess file has been deleted or overwritten.
    Possibly when you installed Arrow Chat.

    You will need to restore the XenForo .htaccess file by renaming htaccess.txt to .htaccess.
  4. Jayt

    Jayt Member

    Friendly URLS is disabled and the .htaccess and htaccess.txt files are identical. I moved the existing .htaccess and renamed the htaccess.txt to .htaccess and there was no change.
  5. Jayt

    Jayt Member

    Here's what's in the .htaccess if it helps:

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]

Share This Page