1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Problem importing

Discussion in 'Installation, Upgrade, and Import Support' started by Jesper32, Feb 12, 2016.

  1. Jesper32

    Jesper32 Member

    Hi guys

    So I just bought a license, and set a test site locally.

    I'm trying to import my old database using bigdump, as the "Import External Data" for some reason gives me an error "The source database connection details are not correct: MySQL server has gone away".

    I can import it with success with bigdump, but I can't see any data has been added to the site. Do I need to do anything else after import?

    I know it's a noob question, but I'm not that experienced :)

  2. Brogan

    Brogan XenForo Moderator Staff Member

    It's not clear what steps you have taken.

    If you have only just bought a license, you can't import your old database into XF as presumably it is from another forum software.

    You would first need to install XF locally, then import your old database into MySQL, then do the XF import from the ACP.

    If it's the import into MySQL which is failing, try using a shell session to import it.
    mysql -uroot -proot database_name < backup.sql
  3. RoldanLT

    RoldanLT Well-Known Member

    Try to import/export it using Sypex first.
  4. wang

    wang Well-Known Member

    It sounds like you are not entering your database details correctly? From what forum are you trying to import?

    Bigdump has nothing to do with importing from one forum to another. Bigdump merely restores a database. And if you are trying to restore the database backup of your other forum to xenforo, it will not work. Can you please provide a step ny step account of how are you trying to do the import?
  5. Jesper32

    Jesper32 Member

    Sorry, I'll try to be more specific.

    I'm using XAMPP to get it running locally by the way.

    I run a phpBB3 board also. And from within the ACP of that board I do a backup of the database. It's quite a large database (600 MB), so doing it from phpmyadmin, is not that easy.
    After that I import it to the local phpmyadmin, also without issues. But when I try to "Import External Data" from within the ACP of xenfora I get that error.

    One of the mistakes I did at first, was simply to put server address as my phpmyadmin of my phpBB3 board, but obviously that doesn't work. After doing it with "localhost" I thought I got it, but received a "ErrorException: Fatal Error: Maximum execution time of 240 seconds exceeded - library\XenForo\Application.php:316" error.
    I did however follow this guide: https://xenforo.com/community/resources/how-to-install-xenforo-locally-to-your-pc-using-xampp.355/ and added the values suggested at the end.

    So right now I'm stuck again.

    If I do a http://localhost:8080/community/admin.php?tools/phpinfo I can see that the "Core" "Local value" is still 240 but the "Master value" is 5000.
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Using PhpMyAdmin to backup a database that large is not recommended,

    I recommend using a shell session or some other program which is better suited to dealing with large databases.

    You may also need to modify your XAMPP installation to change some of the PHP and MySQL values - in the same way you would tune a server - which you have done according to the guide I posted.

    If the local value is not changing then it sounds like you need to modify one of the other ini files, create a local ini file, or possibly even restart the 'server'.
  7. Jesper32

    Jesper32 Member

    Ok, I made a complete reinstall and finally got it working.

    Thanks a lot guys for your suggestions.

    @RoldanLT I used Sypex to export/import my database, and it worked like a charm. Will definitely use Sypex from now on :)
    RoldanLT likes this.

Share This Page