1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Postloop Integration

Discussion in 'Add-on Releases [Archive]' started by Ryan, Jul 27, 2011.

  1. Ryan

    Ryan Well-Known Member


    This will allow for integration of Postloop into your forums. Postloop is a website that offers forum owners a way to get more posts in their forums, either by exchanging or by purchasing. I won't go into details about how Postloop works, but you can read more about it here. If you don't know what Postloop is, this mod will mean very little to you :)

    In order for Postloop to operate, each participating forum must be able to report post counts back to Postloop so that it knows when a "Postlooper" makes a post. This addon sends back basic information to Postloop when asked for it. To learn more about our data collection practices, go here.

    • Upload the included /library/ folder to your XenForo root directory
    • Log into your XenForo Administration Panel and click "Install Add-on" in the left-hand navigation
    • Find the "Install from file on server:" text field and enter the following: library/Postloop/addon-Postloop.xml
    • Click here to submit your forum to the Postloop listings
    • Upload the included /library/ folder to your XenForo root directory
    • Log into your XenForo Administration Panel and click "List Add-ons" in the left-hand navigation
    • Expand the Controls dropdown for Postloop and select Upgrade
    • Find the "Upgrade from file on server:" text field and enter the following: library/Postloop/addon-Postloop.xml

    • v1.0.2:
      • Added XenForo version number to "ping" action to better handle software upgrades and conversions on the Postloop backend
    • v1.0.1:
      • Removed $test parameter from main method which was causing conflicts with other XenForo addons.
    • v1.0.0:
      • Initial release

    Attached Files:

    bogus, ankurs and Mikey like this.
  2. Mikey

    Mikey Well-Known Member

    Ryan likes this.
  3. Savvy

    Savvy Member

    I've installed it. :)
    Ryan likes this.
  4. bogus

    bogus Guest

    Nice. Saw it on vb and was waiting for it. Thanks a lot ;)
    Ryan likes this.
  5. Floris

    Floris Guest

    Screen shot 2011-08-25 at 2.05.16 PM.png

    Can install it. Can't complete add forum form on postloop.

    It says postloop.php wasn't found in the root.
    It's not there, because the .zip doesn't have it. Everything's under library/
  6. Ryan

    Ryan Well-Known Member

    So, something about the installed addon does not work in your forums.

    This: http://xenfans.com/postloop?action=ping

    Should display this: http://www.postloop.com/support/postloop?action=ping

    But instead, it's giving a generic exception error: "An unexpected error occurred. Please try again later."

    Unfortunately there's not much that I can do. We've had 15 or so other XenForo users install this addon without trouble. My guess is that you either didn't install the addon correctly or there is a conflicting addon/modification in your forums...neither of which I have any knowledge of.
  7. Floris

    Floris Guest

    The server error log doesn't mention anything ..

    I've unpacked the .zip, uploaded the directory inside library/ and imported the .xml

    Nothing much more I can do ..

    Screen shot 2011-08-25 at 2.56.48 PM.png
    Screen shot 2011-08-25 at 2.57.18 PM.png
  8. Floris

    Floris Guest

    It seems to be caused by TiagraChat (shoutbox)

    An exception occurred: Declaration of Dark_TaigaChat_ControllerPublic_Index::actionIndex() should be compatible with that of Postloop_ControllerPublic_Postloop::actionIndex() in /home/xenfans/public_html/library/Dark/TaigaChat/ControllerPublic/Index.php on line 77
    1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
    2. XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
    3. XenForo_Autoloader->autoload() in XenForo/Application.php at line 852
    4. XenForo_Application::autoload() in XenForo/Application.php at line 397
    5. XenForo_Application::resolveDynamicClass() in XenForo/FrontController.php at line 402
    6. XenForo_FrontController->_getValidatedController() in XenForo/FrontController.php at line 302
    7. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    8. XenForo_FrontController->run() in /home/xenfans/public_html/index.php at line 13
  9. Ryan

    Ryan Well-Known Member

    Roger, that's what I needed. I've submitted v1.0.1 which will fix address that issue.
  10. Floris

    Floris Guest

    Much appreciated. Giving it another go.
  11. Floris

    Floris Guest


    edit: worked, i was able to submit site.
    Cezz and Ryan like this.
  12. Ryan

    Ryan Well-Known Member

    Updated to make things more seamless when you undergo a major XenForo upgrade, or convert to/from XenForo.

    This isn't a required update.

Share This Page