• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

******* - Post Thanks Importer [Deleted]

Status
Not open for further replies.

aculate

Well-known member
#2
I just imported my vB3.8.4 data using this app, and i don't see the Import Post Thanks action button, therefore no import of my post thanks from vBulletin to XenForo likes.

Can you confirm that this works on vB 3.8.4 and xenForo 1.3 ?

Thanks
 

Brivium

Well-known member
#3
I just imported my vB3.8.4 data using this app, and i don't see the Import Post Thanks action button, therefore no import of my post thanks from vBulletin to XenForo likes.

Can you confirm that this works on vB 3.8.4 and xenForo 1.3 ?

Thanks
This addon allows you to import post thanks from vBulletin (3.7 / 3.8 / 4) to XenForo likes.

Please check again
 
#5
After install it I met this error:
ErrorException: Fatal Error: Cannot redeclare class XFCP_*******_PostThanksImporter_Importer_vBulletin - library/XenForo/Application.php(514) : eval()'d code:1
Generated By: rootadmin, Hôm nay lúc 02:35
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
["url"] => string(46) "http://shoptinhoc.com/forums/admin.php?import/"
["_GET"] => array(1) {
["import/"] => string(0) ""
}
["_POST"] => array(0) {
}
}

any one help me to fix?
 

Brivium

Well-known member
#6
Hello,

You can try to open file library\*******\PostThanksImporter\EventListeners\Listener.php and replace all contents with
Code:
<?php

class *******_PostThanksImporter_EventListeners_Listener extends *******_*******Library_EventListeners
{
    public static function loadClassModel($class, &$extend)
    {
        switch($class){
            case 'XenForo_Model_Import':
                $extend[] = '*******_PostThanksImporter_Model_Import';
                break;
        }
    }
    protected static  $_dismissed = null;
    public static function loadClassImporter($class, array &$extend)
    {
        switch($class){
            //case 'XenForo_Importer_vBulletin':
            case 'XenForo_Importer_vBulletin36x':
            case 'XenForo_Importer_vBulletin4x':
                if(is_null(self::$_dismissed)){
                    $extend[] = '*******_PostThanksImporter_Importer_vBulletin';
                }
                break;
        }
    }
    public static function templateHook($hookName, &$contents, array $hookParams, XenForo_Template_Abstract $template)
    {
        self::_templateHook($hookName, $contents, $hookParams, $template);
    }
}
 

Dakis

Well-known member
#7
This doesn't work - gives me the same error as above. I replaced the listener.php with the contents above, still doesn't work. It also gives a blank page every time you try to visit the import page. I have to uninstall it to get access to the importer.

XenForo 1.3 that has just been installed, no addons no nothing.
 
#8
Hello, I tried your add-on and I received this error message on a blank page:

Fatal error: Cannot redeclare class XFCP_*******_PostThanksImporter_Importer_vBulletin in /home/xfasb/public_html/library/XenForo/Application.php(514) : eval()'d code on line 1

Any suggestion?

I'm using XF1.3.1 and importing from VB4.2.1

Thanks
 

Bob_R

Active member
#9
I have the same problem as Parafal in the post above this one except it's for vBulletin 4.2.2

His post is a month and a half old. I guess I won't be getting an answer nor using this add on for the import which is a bummer because I wanted to keep my thanks for vBulletin.

This add-on doesn't work.
 
#13
This doesn't work - gives me the same error as above. I replaced the listener.php with the contents above, still doesn't work. It also gives a blank page every time you try to visit the import page. I have to uninstall it to get access to the importer.

XenForo 1.3 that has just been installed, no addons no nothing.
Any news for the error? I have the same problem
 
#17
If it may be of interest, the official importer of xf1.4 includes importing thanks from vbulletin
it is not
Hello, I tried your add-on and I received this error message on a blank page:

Fatal error: Cannot redeclare class XFCP_*******_PostThanksImporter_Importer_vBulletin in /home/xfasb/public_html/library/XenForo/Application.php(514) : eval()'d code on line 1

Any suggestion?

I'm using XF1.3.1 and importing from VB4.2.1

Thanks
same error for me. is there any solution for this?
 
Status
Not open for further replies.