1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

******* - Post Thanks Importer [Deleted]

Discussion in 'Add-on Releases' started by Brivium, Feb 10, 2014.

Thread Status:
Not open for further replies.
  1. Brivium

    Brivium Well-Known Member

    ******* submitted a new resource:

    ******* - Post Thanks Importer - This addon allows you to import post thanks from vBulletin to XenForo likes.

    Read more about this resource...
  2. aculate

    aculate Well-Known Member

    I just imported my vB3.8.4 data using this app, and i don't see the Import Post Thanks action button, therefore no import of my post thanks from vBulletin to XenForo likes.

    Can you confirm that this works on vB 3.8.4 and xenForo 1.3 ?

  3. Brivium

    Brivium Well-Known Member

    This addon allows you to import post thanks from vBulletin (3.7 / 3.8 / 4) to XenForo likes.

    Please check again
  4. Brivium

    Brivium Well-Known Member

    aculate likes this.
  5. gunnerit

    gunnerit New Member

    After install it I met this error:
    ErrorException: Fatal Error: Cannot redeclare class XFCP_*******_PostThanksImporter_Importer_vBulletin - library/XenForo/Application.php(514) : eval()'d code:1
    Generated By: rootadmin, Hôm nay lúc 02:35
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(46) "http://shoptinhoc.com/forums/admin.php?import/"
    ["_GET"] => array(1) {
    ["import/"] => string(0) ""
    ["_POST"] => array(0) {

    any one help me to fix?
  6. Brivium

    Brivium Well-Known Member


    You can try to open file library\*******\PostThanksImporter\EventListeners\Listener.php and replace all contents with
    class *******_PostThanksImporter_EventListeners_Listener extends *******_*******Library_EventListeners
        public static function loadClassModel($class, &$extend)
                case 'XenForo_Model_Import':
                    $extend[] = '*******_PostThanksImporter_Model_Import';
        protected static  $_dismissed = null;
        public static function loadClassImporter($class, array &$extend)
                //case 'XenForo_Importer_vBulletin':
                case 'XenForo_Importer_vBulletin36x':
                case 'XenForo_Importer_vBulletin4x':
                        $extend[] = '*******_PostThanksImporter_Importer_vBulletin';
        public static function templateHook($hookName, &$contents, array $hookParams, XenForo_Template_Abstract $template)
            self::_templateHook($hookName, $contents, $hookParams, $template);
  7. Dakis

    Dakis Well-Known Member

    This doesn't work - gives me the same error as above. I replaced the listener.php with the contents above, still doesn't work. It also gives a blank page every time you try to visit the import page. I have to uninstall it to get access to the importer.

    XenForo 1.3 that has just been installed, no addons no nothing.
  8. Parafal

    Parafal Member

    Hello, I tried your add-on and I received this error message on a blank page:

    Fatal error: Cannot redeclare class XFCP_*******_PostThanksImporter_Importer_vBulletin in /home/xfasb/public_html/library/XenForo/Application.php(514) : eval()'d code on line 1

    Any suggestion?

    I'm using XF1.3.1 and importing from VB4.2.1

  9. Bob_R

    Bob_R Active Member

    I have the same problem as Parafal in the post above this one except it's for vBulletin 4.2.2

    His post is a month and a half old. I guess I won't be getting an answer nor using this add on for the import which is a bummer because I wanted to keep my thanks for vBulletin.

    This add-on doesn't work.
  10. Brivium

    Brivium Well-Known Member

    @All: We will fix your reported error shortly.

  11. boa

    boa Member

    Any news for the error? I have the same problem
  12. Tim Jay

    Tim Jay Active Member

    I was able to install this, but I don't see any "Import Post Thanks" step under Import External Data.
  13. AndreaDB

    AndreaDB Member

    Any news for the error? I have the same problem
  14. boa

    boa Member

    pity there is noone to fix the bug
  15. AndreaDB

    AndreaDB Member

    If it may be of interest, the official importer of xf1.4 includes importing thanks from vbulletin
  16. boa

    boa Member

    I impored by 1.4 but the thanks for the post is not imported. The reputation maybe
  17. radu81

    radu81 Member

    it is not
    same error for me. is there any solution for this?
  18. ophy

    ophy Member

    I get an error when I try to install the actual addon in 1.4.3. It just says Invalid File. Any idea how to fix?
  19. nrep

    nrep Well-Known Member

    I'm getting the same error on installation too.
  20. DivokyMuz

    DivokyMuz Member

    Same Error for me, XF 1.4.4
Thread Status:
Not open for further replies.

Share This Page