• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Plesk Enhancements - Now supports Percona and MariaDB + Full Nginx

Slavik

XenForo moderator
Staff member
#1
I've been lobbying Plesk for 3rd party database server support for a long time now. As Plesk users will know, previously if you swapped out MySQL for Percona or MariaDB, it would break things horribly.

Anyway, as of the release of Plesk 11.5, it is now possible to swap out MySQL server for Percona and MariaDB.

I've put a guide together here: http://xenforo.com/community/resources/upgrade-to-percona-server-on-a-plesk-server-or-vps.2121/

We are already running it on P8ntballer. Huzzahs all around


Also included in this update is full Nginx web server support (You will need to add the remi repo before enabling this option). So not only can it be set up as a reverse proxy as is easily available in current plesk and cpanel versions, but it can now be set up with php-fpm to allow Nginx to serve all content on your site.

A full changelog can be found here: http://download1.parallels.com/Ples...lels-plesk-panel-11.5-for-linux-based-os.html
 

p4guru

Well-known member
#2
Wow that is good news for Plesk users. Makes sense regarding Percona and MariaDB as alot of linux distros are making MariaDB the default MySQL version.

Full Nginx support good too.
 

Carla Birch

Well-known member
#3
I can run Nginx fine, but once i turn on php-fpm for Nginx i get 404 errors on my sites, i have no idea why lol. Some times i hate servers, maybe one day i'll take the time to learn :p
 

Marcus

Well-known member
#4
I can run Nginx fine, but once i turn on php-fpm for Nginx i get 404 errors on my sites, i have no idea why lol. Some times i hate servers, maybe one day i'll take the time to learn :p
see below:
Also included in this update is full Nginx web server support (You will need to add the remi repo before enabling this option). So not only can it be set up as a reverse proxy as is easily available in current plesk and cpanel versions, but it can now be set up with php-fpm to allow Nginx to serve all content on your site.
You can not even change the / location with Plesk 11.5 fpm nginx. It's only for serving static files and not for any serious things like community software.
 

Slavik

XenForo moderator
Staff member
#5
see below:

You can not even change the / location with Plesk 11.5 fpm nginx. It's only for serving static files and not for any serious things like community software.

Sounds like your not configuring it correctly.

Have you created the relevent vhost_nginx.conf file?
 

Marcus

Well-known member
#9
Pardon my english. You always get an error message once you have a custom nginx.conf with location /. Plesk isn't happy you provide a location that is already described in Plesks standard configuration.

/etc/nginx/nginx.conf includes lots of other configuration files. I will remove these includes and hope Plesk won't put them there again.
 

Slavik

XenForo moderator
Staff member
#10
Pardon my english. You always get an error message once you have a custom nginx.conf with location /. Plesk isn't happy you provide a location that is already described in Plesks standard configuration.

/etc/nginx/nginx.conf includes lots of other configuration files. I will remove these includes and hope Plesk won't put them there again.

If you specify a custom vhost_nginx.conf file for a domain is will override the server-wide policy conf file in the same way a custom vhost.conf for a domain overrides the server-wide apache profile.
 

Marcus

Well-known member
#11
If you specify a custom vhost_nginx.conf file for a domain is will override the server-wide policy conf file in the same way a custom vhost.conf for a domain overrides the server-wide apache profile.
How did you do that? Do you also use Plesk 11.5 and nginx?

I always get the same error also mentioned in the plesk support forum.
 

Marcus

Well-known member
#12
This is how it works on a Plesk server with 100% manually nginx configuration:

/etc/nginx/nginx.com
-> outcomment the inclusion lines:
# include /etc/nginx/conf.d/*.conf;

Then you can edit nginx.conf. Don't forget to "service nginx restart" after each edit.