1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pictures Not Uploading

Discussion in 'Server Configuration and Hosting' started by Grizzly Adam, Oct 30, 2014.

  1. Grizzly Adam

    Grizzly Adam Active Member

    We just transferred our site to our new host last night. This morning it was noticed that when users attempt to upload pics, they do not properly upload (if at all). Does anyone have any ideas?

    image.jpg
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Navigate to admin.php?tools/phpinfo

    Check if jpeg support is enabled.
    It should be under GD.

    upload_2014-10-30_12-47-21.png
     
    Chris D likes this.
  3. Grizzly Adam

    Grizzly Adam Active Member

    image.jpg Here is is the only reference to JPEG or jpg on that page.
     
  4. Grizzly Adam

    Grizzly Adam Active Member

    There is no GD section whatsoever.
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    I suspect that's the issue then.

    You need an image processor library - GD is the typical built in default.

    Contact your host and ask them to install it.
     
  6. Grizzly Adam

    Grizzly Adam Active Member

    Thanks Bro.
     
  7. Grizzly Adam

    Grizzly Adam Active Member

    Yes, this was the issue. We got GD installed and everything is fixed.
     
  8. Grizzly Adam

    Grizzly Adam Active Member

    Does this have anything to do with size? Users are now unable to upload files the same size that they have always used, even after increasing file size and pixel size limits under options.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Without knowing the error message it's difficult to say, but I suspect you will need to adjust some PHP values.
     
  10. Grizzly Adam

    Grizzly Adam Active Member

  11. Brogan

    Brogan XenForo Moderator Staff Member

    You may need to adjust max_upload_size.
     
  12. Grizzly Adam

    Grizzly Adam Active Member

    Can you give me just a little more guidance on where to locate this? In library?
     
  13. Brogan

    Brogan XenForo Moderator Staff Member

    It's in the php.ini file.
     
  14. Grizzly Adam

    Grizzly Adam Active Member

    This is as close as I could find. Increase the size to 8m, still the error persists,

    ;;;;;;;;;;;;;;;;
    ; File Uploads ;
    ;;;;;;;;;;;;;;;;

    ; Whether to allow HTTP file uploads.
    ; http://php.net/file-uploads
    file_uploads = On

    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    ; http://php.net/upload-tmp-dir
    upload_tmp_dir = /home/server/tmp

    ; Maximum allowed size for uploaded files.
    ; http://php.net/upload-max-filesize
    upload_max_filesize = 8M

    ; Maximum number of files that can be uploaded via a single request
    max_file_uploads = 20
     
  15. WSWD

    WSWD Well-Known Member

    Change post_max_size as well.

    And when you're finished doing that, restart your HTTP server.
     
  16. Grizzly Adam

    Grizzly Adam Active Member

    It finally sorted out, just took some time after edit. Thanks guys.
     

Share This Page