• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 PHP UTF8

rv65

Active member
#1
An exception occurred: Call to undefined function utf8_decode() in /srv/www/community/library/Lgpl/utf8.php on line 96

utf8_strlen() in XenForo/Helper/String.php at line 581
XenForo_Helper_String::wholeWordTrimAroundSearchTerm() in XenForo/Template/Helper/Core.php at line 1208
XenForo_Template_Helper_Core::helperSnippet() in XenForo/Template/Helper/Core.php at line 853
XenForo_Template_Helper_Core::callHelper() in XenForo/Template/Abstract.php(265) : eval()'d code at line 494
eval() in XenForo/Template/Abstract.php at line 265
XenForo_Template_Abstract->_renderInternal() in XenForo/Template/Abstract.php at line 191
XenForo_Template_Abstract->render() in XenForo/Template/Public.php at line 110
XenForo_Template_Public->render() in XenForo/ViewRenderer/HtmlPublic.php at line 124
XenForo_ViewRenderer_HtmlPublic->renderContainer() in XenForo/FrontController.php at line 637
XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
XenForo_FrontController->run() in /srv/www/community/index.php at line 13


Getting this error now. I have PHP7, and I got apache working finally. I still can't get some portions to work though and hard to view threads.
 
#3
Thank you for posting your solution. Installing php-xml after an Ubuntu update (to version 16.04.2) solved this problem for me as well.