• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 permissions issue

xmlxp

Active member
#1
Registred users who belongs to Registred usergroup claim that they cant edit or delete thier posts

I checked Registered usergroup pemissions: edit and delete are allowed (Green)
I checked the node permissions for Registered usergroup: edit and delete are allowed (Green)

I am totally confused
 

xmlxp

Active member
#3
Hello Borgan

all other user groups are set to allow edit and delete for that node, exept the banned userg group which are not allowed
 

Jake Bunce

XenForo moderator
Staff member
#4
What about the time limit?

Admin CP -> Users -> List User Groups -> [click the group] -> Time limit on editing/deleting own posts (minutes)
 

xmlxp

Active member
#5
What about the time limit?

Admin CP -> Users -> List User Groups -> [click the group] -> Time limit on editing/deleting own posts (minutes)
its set to un limited

could this issue caused by a browser caching? i havent asked those users to try another browser
 

Jake Bunce

XenForo moderator
Staff member
#6
Then I agree with Brogan. There must be a "Never" permission somewhere in one of that user's groups. Check the group permissions, node permissions, and user permissions if you have set any.

edit - and it is important to reproduce the problem first. You can't fix a problem that you can't reproduce. Don't trust your users.
 

xmlxp

Active member
#7
Don't trust your users.
You got that right.

I tried one of the complaining members password and i was able to edit and delete. Definitely its the browsers caching system. Is thier any thing i can do from website or server side to solve members browsers caching system problem?