XF 2.2 Permissions Issue

Darcness

Member
Running into permissions issue that I don't seem to have elsewhere on my forum.

I have a user who is a member of four groups: Group A (their Primary group), Group B, Group C, Group D. The permissions structure on my forum is pretty complicated, so all usergroups have their group 'View Node' permission set to 'No'.

I have a Category (Category a) at the main level of the forum, which contains a single forum (Forum 1).

I have set the 'View Node' permission for Group D on Forum 1 to 'Yes'.

When I Analyze Permissions for the user in question, this is what I see:

View Node: No (Details)
Group A: No
Group B: No
Group C: No
Group D: No
-- Forum 1 - Group D: Yes

Why isn't View Node still 'No' here? Shouldn't the node-specific permission be overriding?

As a separate note, I tried giving the specific user a 'Yes' for 'View Node' on Forum 1, but got the same result: they can't see the node. This similar permission structure is working elsewhere on the forum, I'm not sure why this new user (and the new group I created for them) aren't working like other groups.
 

Black Tiger

Active member
Just a guess. Could it be due to Category permissions?
If you have the view node there to NO also, and you don't have set group D to yes, then this would also cause a result like shown now, if I'm not mistaken.
 
Top