XF 2.2 Permission troubles

RobynLJ

Active member
I have set up a user group (lets call it Group A) with appropriate permissions and only that user Group A has access to a particular node.

In the nodes permission area I have set up so that user Group A to have full permissions for this particular node.

My problem is this. At my site I have 3 different identities (apart from my admin log in) so that I can check on how things look from a non-admin perspective. When I log in with Identity 01 I can see this node, BUT when I log in with either Identity 02 or Identity 03 this node is not visible to me.

I have checked all three memberships (the new user group is checked for all) and as far as I can see they all have identical permissions. How can this be?

Your thoughts/suggestions would be greatly appreciated. Thank you.
 
Solution
This has now been resolved.

It was due to the parent category and the forum being set as private and only one of the accounts was explicitly granted permission to view the forum.

Max Taxable

Well-known member
All accounts when registered are by default in the "Registered" usergroup. So anything that is permissioned for that group, all registered can see and access.
 

RobynLJ

Active member
Registered members are not granted permission to see this forum. Group A members do have permission.

My three identities all belong to secondary user group...... Group A, but only one of my identities can see this forum. I'm not at all technically minded, so I can't see what I'm missing here??
 

Lawrence

Well-known member
Let's say your private node is named Pets.

Pets -> Permissions -> Registered: Set all permissions to No (don't use Never).

Pets -> Permissions -> Group A: Set all applicable forum permissions to Yes.

Analyze permissions -> Node permissions -> User -> 02, Content -> Pets, to verify.

Note that analyze permissions may not always reflect the actual permissions users may have due to add-ons installed and how they may interact with forum permissions, but it is still a very useful tool.
 

Black Tiger

Active member
Registered members are not granted permission to see this forum. Group A members do have permission.
Are these all explicit NO and YES, because if you used inherited on the secondary groups, then the explicit NO might be working in these cases.
Check other secondary groups. For example, if you have group A as secondary, but also have a group donators for some users as secondary, and the group donators have an explicit NO, then also access can be denied.

See if this (click) can help you a bit further.
 

RobynLJ

Active member
Thank you @Black Tiger and @Lawrence. Everything as you mentioned above is as it should be. That private forum is only visible to one of my three identities. This is not a deal breaker for me as this forum is rarely used, but I'm like a dog with a bone with a problem. I hate not being able to work out why! I will look into it further. So frustrating!
 
Top