XF 2.2 Paypal IPN notification warnings after converting from VB3.x to XF2.2

oldford

Active member
I recently converted from VB3.x to XF2.2 and I'm now having issues with Paypal still trying to send IPN communications back to my old VB notification URL.

I know that recurring payments do not import from VB to XF. So I've been manually cancelling those auto payments before they renew. But even after I cancel them Paypal still tries to send IPN notifications to my old VB URL on the day the auto payment would have renewed. Those notifications error out, and eventually Paypal disables my IPN because of too many errors.

I spoke to Paypal tech support and they suggested turning off IPN messages just for my old VB URL. Unfortunately in my Paypal settings I only have one IPN. I don't have an old VB one and a new XF one. When I converted to XF I simply changed the URL in the IPN settings from the old VB URL http://mysite.com/forums/payment_gateway.php?method=paypal to the new XF URL : https://mysite.com/forums/payment_callback.php?_xfProvider=paypal

Does anyone know if there's a way to recreate the old VB IPN so I can then go into Paypal and turn it off? My old VB forum is still up so I tried turning the Paypal API manager back on again, but that didn't create a new IPN entry on the Paypal side.

Thanks!
 

Seeker-Smith

Well-known member
I had the same problem. How many subscribers do you have? I found it easier to keep my old vb running as a limited hidden vhost to except the ipn calls. I hen used a redirect in my xenforo htaccess to redirect the ipn calls to the hidden vhost.

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
RewriteRule ^payment_gateway\.php$ "https\:\/\/hidden\.site\.com\/payment_gateway\.php\?method\=paypal" [R=301,L]
 
Top